MG-Rover.org Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
404 Posts
Discussion Starter · #1 · (Edited)
Haven't posted here for quite a while, but since I've had some probs with the ZT, I thought I would share them.
I've been noticing some engine noises, and I think they were there at my last service, and not picked up by Trident Ottershaw, although they appear to be more noticable now. The noises are firstly a rasping/scraping noise coming from the left side, possibly from the drive belt on that side. The other noise was tapping/clattering coming from the top/rear of the engine. Other problems which are probably linked are rough idle, hot starts not a nice clean start and fuel economy/performance poor. Anyway as my 3yr warranty is due to run out in September, it was high time I had the ZT looked at. Not keen on Trident, which is who I bought the car from, so decided to try Guava Guildford/Godalming. They pinpointed the tapping to be the inlet manifold valves staying closed when they should be opening. Permission from MG-Rover had to be obtained because the parts alone were over £500. So, complete inlet manifold replaced and car returned to me, started her up and yes much better, tapping gone, still a slight rasp from that drive belt though. Anyway, I was pleased, they done a good job. Just about to drive off, and noticed the amber engine light on! So, straight back in the workshop, 20mins later, service mngr brings car round, but says they are still not happy with it.
They have been back to MG-Rover, who have told them to order up another inlet manifold and some oxygen thingy. Parts should arrive Friday/Monday.
In the meantime, I am driving around with engine light on permanately, which apparently will not harm the engine. The fitting of the manifold has made a big difference, smoother and quieter, and pulls better.
I'm happy to recommend Guava Guildford, excellent service so far, at least they are listening to me, which is more than Trident did. Also got some new MG badges on order, as the laminate on mine is breaking up.
I'll keep you posted on any developments.
Phew, need a :beer: after that!
 

·
Registered
Joined
·
836 Posts
Don't know if this is the same thing or not...

Is yours a V6 ????


On my 190 i had this...

Engine was rough on idle and a loud ticking from the engine on idle...

Orange light come on, MG AA assist were called and car taken away...

They put it on the Computer and found nothing wrong, but they reset something and it cleared...

It still ticks after a very long run on idle only but other than that no problems what so ever with the car... Had it since December 2003 brand new and now have covered 13k with the car....

Just need to get the wheel alignment done ...
 

·
Registered
Joined
·
836 Posts
I lie....

I have a few little problems...

Eg boot not opening with internal release

Drivers door not opening from outside...
 

·
Registered
Joined
·
3,847 Posts
REDevil said:
Not keen on Trident, which is who I bought the car from, so decided to try Guava Guildford/Godalming.
Its funny how different people get treated differently by different garages!

Do you know what their maintaince costs are like at all, Guava is the only garage that I have not tried round here, S'n'Js being the usual, defecting to Trident when they patronise me?
 

·
Registered
Joined
·
404 Posts
Discussion Starter · #6 ·
Big GT said:
Don't know if this is the same thing or not...

Is yours a V6 ????


On my 190 i had this...

Engine was rough on idle and a loud ticking from the engine on idle...

Orange light come on, MG AA assist were called and car taken away...

They put it on the Computer and found nothing wrong, but they reset something and it cleared...

It still ticks after a very long run on idle only but other than that no problems what so ever with the car... Had it since December 2003 brand new and now have covered 13k with the car....

Just need to get the wheel alignment done ...
Yes it's a V6 160+.
They hooked mine up to the computer as well, cleared the codes, but the amber engine light came back on, and has stayed on. Hence the need for some more parts I guess. BTW I've done 17.5K in mine.
I also need, the wheels aligned as well, and two new tyres. Still undecided what tyres to go for, didn't really want to start another thread about tyres though. Should have had the tracking done earlier really :banghead: just haven't got around to it.
If anyone has recommendations for ZT tyres, and where to get them, feel free to pitch in.
 

·
Registered
Joined
·
5,662 Posts
Viz valves are getting more common, ( or just hearing about them more )
I have priced them up for our ZS , going to cost around £300 for the complete manifold, but tbh not noticed any lack of performance,the obd says mine are stuck open.
A colleague of mine has a ZT190 12k on the clock,never driven hard,iirc 2 years old and they just been replaced too.

Hey ho :(

Lates
 

·
Registered
Joined
·
404 Posts
Discussion Starter · #8 ·
r44712 said:
Its funny how different people get treated differently by different garages!

Do you know what their maintaince costs are like at all, Guava is the only garage that I have not tried round here, S'n'Js being the usual, defecting to Trident when they patronise me?
I had the 30k/2yr service done by Trident, which they quoted £270 ish, when I picked the car up, it was £311, they'd done a brake fluid change which accounted for the extra £41. Taking the p :cus: s, surely a brake fluid change comes under the service, and if not they should have told me that was extra.
I had got a quote from Guava at the time, which I think was £240, but decided on Trident, thinking they would look after me, as I bought the car from them. :shake:
Surprised, you haven't tried Guava, as you're Guildford based.
 

·
Registered
Joined
·
404 Posts
Discussion Starter · #9 · (Edited)
lates said:
Viz valves are getting more common, ( or just hearing about them more )
I have priced them up for our ZS , going to cost around £300 for the complete manifold, but tbh not noticed any lack of performance,the obd says mine are stuck open.
A colleague of mine has a ZT190 12k on the clock,never driven hard,iirc 2 years old and they just been replaced too.

Hey ho :(

Lates
This problem seems like it is more common than I first thought.
ZT inlet manifold is £500, labour is £300, so I'm just glad its still within warranty. :)
And they ain't fixed it yet!
 
1 - 9 of 9 Posts
Top