MG-Rover.org Forums banner

1 - 2 of 2 Posts

·
Registered
mg_zt
Joined
·
32 Posts
Discussion Starter · #1 ·
hi, i have a zt cdti on an 04 plate which is coming up on 30k miles. basically when the engine is idling it is all over the place and hunting etc and also driving at low revs the engine surges and is uncomfortable to drive... other than that tho engine is serviced and otherwise runs fine...

anyone got any ideas

it also has a roverron box on it and does it regardless of it being on or off. i have tried disconnecting the maf sensor briefly and it still idles rough altho i havent driven it with the maf off.

any one got any ideas

thanks in advance
 

·
Registered
Joined
·
352 Posts
hi, i have a zt cdti on an 04 plate which is coming up on 30k miles. basically when the engine is idling it is all over the place and hunting etc and also driving at low revs the engine surges and is uncomfortable to drive... other than that tho engine is serviced and otherwise runs fine...

anyone got any ideas

it also has a roverron box on it and does it regardless of it being on or off. i have tried disconnecting the maf sensor briefly and it still idles rough altho i havent driven it with the maf off.

any one got any ideas

thanks in advance

I had this, and cured it, much to my amazement, by using Millers Diesel Plus in the fuel. It took about two tankfulls to cure. A garage put it on diagnostics, which indicated that all four injectors were injecting for different periods, indicating that the engine management was trying to compensate. So, Millers cured this, presumably by removing deposits on the injector holes, thus improving the spray pattern.You have have nothing to lose.
Good luck

Colin
 
1 - 2 of 2 Posts
Top