MG-Rover.org Forums banner
1 - 8 of 8 Posts

·
Registered
mg_zt
Joined
·
444 Posts
Discussion Starter · #1 ·
Since I bought my ZT a month ago I've started to notice a few squeaks on the clutch pedal, and it is very stiff. Sometimes it also seems to jump a little. I guess this could just be the clutch cable. Is it an easy job?

Anything else I should check b4 buying one? Or a way to make sure it's the issue?
 

·
Registered
Joined
·
1,292 Posts
I don't think there is a cable to the clutch.

It sounds as though the clutch pedal bushes are dry or wearing out. If not it could be the master cylinder piston is becoming worn.
 

·
Registered
Joined
·
2,322 Posts
There is no clutch cable - it's a hydraulic system. The noise is normally just from the pedal box and is nothig to worry about.
 

·
Registered
Joined
·
43 Posts
Mine has started to squeak, but only since I topped up the master cylinder, think mine's just the spring though on the pedal
 

·
Registered
Joined
·
3,847 Posts
Mine has started to squeak, but only since I topped up the master cylinder, think mine's just the spring though on the pedal
How did you manage this, reason I ask is that the clutch mater cylinder is seperate to the one for the brakes?


Edit:

In fact I know its seperate, because when my clutch went on a previous ZT (symptoms simillar to snapped cable), the brakes still worked as normal.
 

·
Registered
Joined
·
1,292 Posts
The manual is confusing regarding this stating that the clutch and brake fluid is linked. But from what I remember, you are correct in saying that they are seperate. The clutch master cylinder is awkward to get to but Simonauris did top is up via a syringe and tube method.
 
1 - 8 of 8 Posts
Top