MG-Rover.org Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 · (Edited)
Wiring!

HELP!!!!.....I am a first time buyer of a 1.8MGF 1999. After putting the roof down 2 days ago, it became stiff so I "forced" it a little..Straight away, the radio stopped, the clock stopped and the lights under the bonnet and boot have both gone out. Every time I put a new fuse in ( 15amp into No 12 socket), it blows immediatley. Could I have stripped a wire somewhere around the heated rear screen wire harness area by forcing the roof???if so, where is the wiring harness to check it?????is it on the nearside or offside??HELP ME PLEEEEEZ!!!!!!
 

·
Registered
Joined
·
17,075 Posts
The heated rear window connector is on the near side nect to the hood hinge and is probably tucked under the carpet on the rear shelf. The wire may easily have got caught in the hood frame near the hinge. I've not heard of this causing fuse 12 failure but it must be possible. If the wiring looks OK try the boot loom.

Is your car fitted with the heated rear window switch and relay?

When my F started blowing radio fuses it was caused by a broken wire or two in the main loom in the boot. On the nearside, next to the boot hinge the loom forms a Y with one leg branching to the boot lid lock and light. If you peel back the outer wrapping by the Y for a couple of inches you may/will see at least 1 broken wire. This is a fairly common problem and just needs a new section of wire/loom splicing in.
 
1 - 3 of 3 Posts
Top