MG-Rover.org Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter · #1 ·
hi all, Firstly to say that I wish I had been at the meet but......
Anyhow my windscreen washers on my 02 cdt seem to have stoped working!
Where is the pump? where do I get one from? and how much? is it an easy job? or could there be any other causes?

cheers Ian C.
 

·
Registered
Joined
·
1,013 Posts
Hi, my washer jets too had packed up, there are a lot of threads on this but this is what I did when mine went belly up,
Obviously make sure there is water in there!

Make sure you can hear the pump whirring, If you can, like I could, you can modify a fork, by bending the prongs you can easily remove the firtree clips that hold the bonnet insulation to the bonnet, once you have removed all the clips take down the insulation and you will see the washer hose and the plastic T piece connector that has a one way valve, pull off the hose leading to the t connector and aim it away from your engine and face, get someone to hold it and lower the bonnet right down so the wipers don't hit the bonnet, and squirt the washers, if you get a strong squirt of water as opposed to a little dribble then your blockage lies with the jets or more likely the little one way valve, (my 75 has this removed and has a 1.50 halfords basic 3 way connector in its place)
If you get a tiny little bit of water coming out of the hose when the jets are operated, like I did, then you have a blockage at the pump, I made sure the hose was nice and clean and blew down the pipe to the pump, I felt lots of pressure then it cleared, squirted the jets til the stream of water slowed again and blew down the pipe again as above and carried on like that til the bottle was empty and there was no blockage in the hose when I blew down the pipe. After I was satisfied there was no water left in the bottle and no blockage in the pipe I then filled up the bottle with about a pint of hot water and operated the jets, did that til they ran out of water and refilled a couple of times, connected it back up and tested all ok. Been fine ever since.

If you do do this however keep the windscreen wet whilst working the washers or the wipers will mark the screen or it'll damage the wiper motor


Hope this helps and don't blame me if it goes wrong.
 

·
Registered
rover_75
Joined
·
3,524 Posts
Get some one to pull the leaver so it makes the pump work,
Then find out if you can hear the pump working near drivers side wheel.
The pump may well be on the passengers side like the V8 is because i have seen some with it on the other side but just see what side your filler bottle is!

If you cant hear the pump working then it may well be new pump time or may be a wire that has become lose.

If so its a bumper off job! Once it’s off its easy to work on.
 
1 - 3 of 3 Posts
Top