MG-Rover.org Forums banner

1 - 11 of 11 Posts

·
Registered
mg_zt
Joined
·
444 Posts
Discussion Starter · #1 ·
I was getting a noise on the motorway, and I've identified the issue... the drivers window isn't sitting in the rails any more. About half way up the window starts to move towards the front of the car by about 1/2" and stays out of the guides at the rear of the window all the way up, causing it to be out of the guide rails at the top about half way along. It has bent the rubber stripping now, encouraging it to jump out even when I hold onto the window hard as it goes up.

It moves into place easy enough, but not when you're doing 80 on the motorway and especially not at the very top.

Should I just take the door card off and adjust something?/ what am I looking for? Just like to get an idea before I start, I don't want to get half way and have to drive around without a door card because I can't work it out.
 

·
Registered
mg_zs
Joined
·
718 Posts
take it off mate, and see if the bolts on the guide rail are holding the glass properly, might as well remove the whole eindow and have a good look at the rubber guides on the side if you say they are permanently damaged.

an the end of the day if you still aint sorted it you canput the door card back on and get a garage to look.
 

·
Registered
Joined
·
4,115 Posts
there's an adjustement for that inside the door card but I think your window seal is damaged.
you should remove the doorcard and see what's going on.
 

·
Registered
mg_zt
Joined
·
444 Posts
Discussion Starter · #4 ·
It seems if I hold it in place as it goes up that it goes into the seal OK. It just needs tightening, I'll have a look tonight if I can adjust.
 

·
Registered
Joined
·
20 Posts
ive got the same problem, ive had a look it seems as if the window mechanism is loose, not where it fastens to the door i checked all them, but loose in its self .I think we need new ones
( i changed the rubber made no difference)
 

·
Registered
mg_zt
Joined
·
444 Posts
Discussion Starter · #6 ·
Yeah, I had it off last night, it does look like there is too much movement of the window, BUT it is actually the runner it is on that slides back and forward as it is supposed to, not the glass lose in it's runner.

It just doesnt seem like it's tight enough in the side seals, I was thinking of replacing the seals, as they are damaged I might give it a go anyway. At least while I have the window out I will be able to get a good look at things, see if there is a way to make the whole thing a bit tighter.
 

·
Registered
Joined
·
44 Posts
seems like this could be a recurring problem... I too am having the same issues... I know all of the window seals on my 400 need replacing, especially the driver's door and driver's side back door...
Can you buy these seals new or will I have to arse about at scrappies to replace them?
 

·
Registered
mg_zt
Joined
·
444 Posts
Discussion Starter · #8 ·
Scrappies will have used ones... not worth it IMO. I rang my local XPart place, £25 for drivers door only... not cheap for 2m of seals, but what are you going to do?

TBH I'm still not sure it's only the seal!
 
1 - 11 of 11 Posts
Top