MG-Rover.org Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
MY CDTI (72K on the clock) has started to make a loud whooshing / hissing noise on acceleration. The funny thing is that Power seems to be better and economy has improved too. However, it does not sound healthy and I am worried what it could be.

Any ideas where to check first. I have had a brief look but blipping the throttle will not reproduce the sound.

I have a TU3B and MAFAM.
 

·
Registered
Joined
·
281 Posts
Sounds like you have a loose or split boost pipe or intercooler. The sound cant really be reproduced at a standstill as the engine only really makes boost under load.
 

·
Registered
Joined
·
70 Posts
MY CDTI (72K on the clock) has started to make a loud whooshing / hissing noise on acceleration. The funny thing is that Power seems to be better and economy has improved too. However, it does not sound healthy and I am worried what it could be.

Any ideas where to check first. I have had a brief look but blipping the throttle will not reproduce the sound.

I have a TU3B and MAFAM.
Hiya,
reach down the back of the engine behind the maf and see if the large air hose to the turbo from the air filter has come off, if it has the best way to get it back on again is from underneath.
Good luck
Nick
 

·
Registered
Joined
·
352 Posts
Hiya,
reach down the back of the engine behind the maf and see if the large air hose to the turbo from the air filter has come off, if it has the best way to get it back on again is from underneath.
Good luck
Nick
How about the rubber hose which connects the intercooler to the inlet manifold. Oil from the EGR valve can attack the rubber and cause a leak. Look at the large dia hose just behind the RHS (if you are standing looking towards the back) of the Radiator, which goes towards the inlet of the manifold. Feel underneath it may be sticky.

Colin
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #5 ·
I had the front section inc flexi hose and CAT replaced last week for £240.00.

I have come to the conclusion that the pipe must have started going a long time ago because the car is performing much better (can get full benefit of TU3 now) and consumption has gone up.
 
1 - 5 of 5 Posts
Top