MG-Rover.org Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
11,233 Posts
£16.50inc vat from RimmerBros. I would try cleaning the connections for the Idle air control valve and Throttle position sensor with some contact cleaner first though, this cured the high and occasionally fluctuating idle issue I had.
 

·
Registered
Joined
·
42,093 Posts
Discussion Starter · #8 ·

·
Registered
Joined
·
2,220 Posts
This seems a little far fetched deano? How would that affect your revs staying high (I ask because i have the same problem - stupid revs).
 

·
Registered
Joined
·
42,093 Posts
Discussion Starter · #12 ·
Deano says:
coolant temp sensor
Deano says:
sounds liek a sensor to check the temp of the coolant
Deano says:
how to that affect revs
I reject your reality and substitute my own says:
he's observant
I reject your reality and substitute my own says:
it tells the engine management if the engine is warm
I reject your reality and substitute my own says:
and will alter the fuel mix accordingly
I reject your reality and substitute my own says:
like a choke
Deano says:
i see
Deano says:
so if i am acclerating hard
Deano says:
and i pull off accelrator
Deano says:
and my revs stay high
Deano says:
its because of thisd coolant temps ensor
I reject your reality and substitute my own says:
yup

Best Auto Insurance | Auto Protection Today | FREE Trade-In Quote
 

·
Registered
Joined
·
42,093 Posts
Discussion Starter · #13 ·
basically, my idle is a bit weird, sometimes its at 1k, then it will jump after accelrator usage to idle at 1.25 or 1.5
and when i am accelrating, the revs dont drop down afterwards very quickly at all. so i fond i am using thebrakes a lot more to scrub off speed.

i asked chris, he says teh coolant temp sensor is buggered.

Best Auto Insurance | Auto Protection Today | FREE Trade-In Quote
 

·
Registered
Joined
·
417 Posts
Does the 'F have a mass air flow sensor as on my old Fiesta Si (ducks for cover) this was displaying exactly what you said.
In fact - stupid me I know it doesn't as I've changed the airbox on mine!

As above then, probably TPS I'd say ;o)
 

·
Registered
Joined
·
42,093 Posts
Discussion Starter · #18 ·
this is my list of symptoms...

when accelerating, the rev needle doesnt move smoothly, it jiggers a bit.
take foot off accelerator and the revs dont die, and sometimes it can feel like it is trying to carry on accelerating.
at idle, sometimes the stays around 1k, other times it rises to 1.25k


first thing, gonna clean teh contacts that sharky said, check teh 820 airbox over, and also see if the TB is dirty or not, will probably give the accelerator cable a once over as well and take it from there.

Best Auto Insurance | Auto Protection Today | FREE Trade-In Quote
 

·
Registered
Joined
·
14,789 Posts
Might be silly, mine was doing similar but more eratic, and sometimes even cutting out, but the pump pedal 5 times reset thingy worked for me, you tried that?
 
1 - 20 of 22 Posts
Top