MG-Rover.org Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9,119 Posts
Discussion Starter · #1 · (Edited)
The K-Series in my 114 has always made a very slight ticking noise at idle, but while it has been off the road waiting for the head gasket to be fixed the noise has become somewhat amplified, now it is more like continuous tapping.

Is this likely to be a problem with the tappets and how much would it cost to fix at a garage?

Thanks.

Liam. :)
 

·
Registered
Joined
·
2,268 Posts
sure its not the injectors? mine are twice as noisey as the tappets.Try an oil change it does help to quieten them.As for a garage=mega bucks!! DIY-a set of them around £60 some unipart ggc108 cam carrier sealant £10
 

·
Registered
Joined
·
17,398 Posts
Indeed fresh oil can have an effect. Just give it a bit of time and a good run. It may take time for them to pressurise fully again as they may have drained while the head was off.
 

·
Registered
Joined
·
9,119 Posts
Discussion Starter · #4 ·
ashy said:
Indeed fresh oil can have an effect. Just give it a bit of time and a good run. It may take time for them to pressurise fully again as they may have drained while the head was off.
The gasket hasn't been done yet, it is still waiting. This noise has developed while the car has been off the road.

Just checked the oil and it is just off the maximum, and no sign of mayo in the oil tank.
 

·
Registered
Joined
·
17,398 Posts
I mean that once the gasket is done and you have flushed all the old crap out and put new oil in then after a good run it should improve.
 
1 - 5 of 5 Posts
Top