MG-Rover.org Forums banner

1 - 3 of 3 Posts

·
Registered
rover_75
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi,

Just got my synergy box today for 2003 75 CDT, done 53000 miles, purchased at 3 months old with 6 miles on clock.

Whipped off the engine cover and moved the air intake no problem, but couldn't undo the electrical block, didn't want to force it as I need the car to drive ;-) Any tips for removing it?

Car is due in friendly garage soon so may have to leave it for them to tackle.

Thanks,

Robert
 

·
Registered
other_manufacturer
Joined
·
4,589 Posts
Hi,

Just got my synergy box today for 2003 75 CDT, done 53000 miles, purchased at 3 months old with 6 miles on clock.

Whipped off the engine cover and moved the air intake no problem, but couldn't undo the electrical block, didn't want to force it as I need the car to drive ;-) Any tips for removing it?

Car is due in friendly garage soon so may have to leave it for them to tackle.

Thanks,

Robert
The maf connector has two clips - one each end. You squeeze these together and the plug will pull off.

The Tu3 connector also has a retaining clip. You squeeze this towards the centre of the plug. It will be stiff or very stiff but will suddenly click free.
Try pushing the plug in slightly as you squeeze it.

Ron
 

·
Registered
rover_75
Joined
·
5 Posts
Discussion Starter · #3 ·
It was the Tu3 connector, I should have studied the new connector on the synergy unit for clues, once I saw how it fits I had no problem pressing the right area of the existing connector.

Only had a 10 miles run tonight, seems great, just Tu3 connected - set on 3, where did my engine braking go? Heading south tomorrow, 400 miles or so, should have some fun ;-)

Thanks
 
1 - 3 of 3 Posts
Top