MG-Rover.org Forums banner

1 - 2 of 2 Posts

·
Registered
rover_75
Joined
·
15 Posts
Discussion Starter · #1 ·
Hi, my 75 cdt club se would not start today only an hour after it had been used.The engine would turn over but would not fire.Called Green Flag came to my house and bugger me it started, bloke turned it off/on/off/on then weird things started. Engine wouldn't turn, clicking noise and the weird thing the headlamps came on for about 10 secs then went off, this happened everytime until he put battery booster on. Then engine cranked ok but would not fire, used some easystart hey presto everything ok. Has anybody got any ideas as to what is the problem.
 

·
Registered
Joined
·
1,505 Posts
Think you've possibly got two problems here not one.

1/ Non Starting. I am on the petrol side of this camp so know a bit more the V6 than the diesel. However I have seen numerous threads on diesel non starting in the circumstances you describe. Suggest you do a search using 'Easystart' and a lot of info will pop up. Also 'Diesel and non starting'.

2/ The headlights coming on when trying to start is the typical behavour of a 75 when the battery is too low and perhaps on the way out. The 75 is very sensitive to battery voltage and if that drops too far the computers wont start up and neither will the car. The headlamps do come on for a bit as a warning of the battery condition. It may be that the attempted starts flattened the battery but it could also be a failing battery. Maybe get it checked out when you have cured problem 1 ?

Hope all this helps.
 
1 - 2 of 2 Posts
Top