MG-Rover.org Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Hi all,

Only had the MG TF for a couple of weeks now and still absolutely loving the car to bits....apologies for not getting any pics up yet as I promised this last week when I first joined! Unfortunately the weather has been pretty bad up here recently and I want a good day to get some really good shots of it.

So any way was out and about today and when turning left and only when turning left I'm hearing a squeaky/tweet tweet sound coming from the back wheel(at least thats where I think it's coming from). I reckon it may just need oiling somewhere or could possibly be a wheel bearing needing replacing but am unsure. I suppose it could also be the brakes rubbing slightly.

So basically my question to anyone is have you had the same problem and know how to fix this? Or do you think it could be the same problem that Andie had with the main wheel nut that was fixed for her by the newly crowned Saint Dave??

Thanks for any help!

Calum
 

·
In the Garage
MG TF
Joined
·
33,184 Posts
I would first investigate the rear wheel bearings to make sure that they are OK.

If that doesn't find anything then I would remove and clean the rear brake pads and put some copper slip on the non-friction side of the pads.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
Cheers Chris...I'll give this a shot...I'm prob best taking this back to the dealer I suppose as it should be covered by warranty somehow.
 
1 - 3 of 3 Posts
Top