MG-Rover.org Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hi

Still having heater issues.

So far I have -

Flushed the system.
Back flushed the rad and heater matrix.
Renewed the Exp. tank cap.
Refilled the coolant.
Bleed the system.

But I still have no hot air coming from the heater.

The coolant seems to be behaving correctly eg. With engine at idle, it heats up and rises a couple of cms in the exp. tank. Then the fan kicks in and the coolant falls about a cm, then it repeats.

Had the car idling for 30mins the fan kicked in about 9 times, but i still don`t get any hot air from the heater.

Please help, any ideas or feedback would be great.

Thanks in advance
Paul
 

·
Registered
Joined
·
4,115 Posts
your temperature control knob is broken, when you turn it to hot, it doesnt actually do anything and you keep getting cold air.
have a look behind the middle console, you'll see a yellow plastic arm that the heat control knob is supposed to pull or push via a cable. turn the knob and see if that arm moves.

you can move that yellow arm manually to switch between cold and hot manually until you get the knob fixed.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
Thanks Tad, but I have already checked the heater knob, everything is connected and the arm moves on the heater valve in the pipe too.
 

·
Registered
Joined
·
4,115 Posts
I'm pretty sure something else in the mechanism is broken.
can you see the collant pipe that goes behind the kick panel? did you touch it to check if it's heats up?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
No, I haven`t tried this yet, I know the pipes entering the bulk-head are hot, but I didn`t know where they went from there. I`ll go check. Thanks
 

·
Registered
rover_200_coupe
Joined
·
694 Posts
Hmmm, with you saying the pipes to the matrix are hot, I would say you either have an air blockage in that part of the system or the heater panel like TAD says is stuck on cold.

When you bled the system, did you turn the heater knob to hot as you were doing it? Also squeezing the pipes as you are filling it helps by pushing the blockages out. Also bit concerned about the fan coming on 9 times in 30 mins.. Anyway, as you continue I would now have another go at re bleeding it with the heater control knob set to max heat .. squeeze the pipes to get as much air as you can to the expansion bottle (As you bleed it, do it without the expansion cap on)

Also, when you release the bleed screw is there any sign of air if so, it still has airlocks in it.

Let us know how you get on.

Sean
 

·
Registered
Joined
·
142 Posts
The water flows through narrow pipes inside the heater matrix. It may be that they are blocked. The only sure way to find this out is to take the matrix out and fill it with hot water, then check for cold areas. You will likely get a second hand matrix for around £20.
 
1 - 7 of 7 Posts
Top