MG-Rover.org Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
This warning light on the dash lights up occasionally. A possible loose connection or gremlins have entered ?
Hopefully a simple answer and not the end of the world
:cool:
 

·
Premium Member
Joined
·
290 Posts
First thing to check is seat-belt connectors. Next would be the steering wheel module. Lot on the forum about this subject. Dont spend money buying spares until you have gone through a process of narrowing it down.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I appreciate your reply will try and narrow down the source of the problem
Thanks from 45 degrees South
 

·
Premium Member
Joined
·
290 Posts
I appreciate your reply will try and narrow down the source of the problem
Thanks from 45 degrees South
Search 'MGTF rotary coupler' and it will give you an idea, but start on the fault-finding process first- as these are about £150 in UK off ebay and a waste of money if its just a seat-belt connector! Too many well-intentioned person will have you changing unecessary stuff- which causes annoyance when it achieved FA progress! Its not something ive had issue with on mine, but ive had these cars for years and its only a question of time!
 

·
Registered
Joined
·
14 Posts
Check out the posting I have just made. The wire under the seat can give problems with the connectors at BOTH ends.

Jan Targosz

2005 TF 135, dark green metallic, black/green leather, 6500 miles from new.
 
1 - 5 of 5 Posts
Top