MG-Rover.org Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi. I own a rover 416i N reg (1996) and recently had the gearbox and clutch replaced. Since i got the car back the speedo hasnt worked. Mileage is stuck too. The mechanic said that it needs a new speedometer switch. is there such thing as a speedo switch? if so, where can i get one of these.

thanks
 

·
Registered
Joined
·
1,108 Posts
It is more like a speed sensor which is actually fitted to the gearbox so if you had this replaced then the mechanic should have removed it to get at the box. I don't know where this is on your motor as i have a 214 but if you have the relevant haynes manual that should tell you where it is.

It sounds to me more like he has either broken the sensor or not refitted it at all. If it was working before they touched it then they must put it right. If they broke it then they pay for it. Someone on here might know where it is fitted on your car so you should be able to check yourself easily.

Hope this helps.
 

·
Registered
Joined
·
5,662 Posts
You have not said if your car is a K series Rover or a D series Honda engine. ? I am guessing a K series and the sensor / transducer is on the back/top edge of the gearbox - very easy to damage while carrying out a clutch repair. I would take the car back and very politely mention worked before you took it to bits.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
thanks for the replies. Unfortunately the mechanic i got it done from is far away from here, I have moved since i had the work done. I guess ill have to visit a scrap yard or something
 

·
Registered
rover_75
Joined
·
54 Posts
Hi! i have an erractic speedometer problem it just bounces up and down... its for a rover 414 1995 new shape model... does anyone know where i can locate the speedometer cable / sensor? is it on top of gearbox or below it? show pictures if possible
 
1 - 6 of 6 Posts
Top