MG-Rover.org Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
hi, i have mg 350D 2012, and a week ago, I wanted to clean my car's monitors and disconnected all cables, when i connected again my time and date reset and it only shows stars, is there any way to set time again?
 

·
Registered
Joined
·
11,876 Posts
The only thing I can see relating to setting the time is the enter or return key on the head unit in the Roewe 350 service manual. It does not state how to actually set the time just says clock setting mode. Press and hold it and see if it makes the time stars flash then use up and down key to change the digits to the correct time and then press enter again.
 

·
Registered
Joined
·
11,876 Posts
The Roewe service manual can be found by googling Roewe 350 service manual.

Cant seem to copy the link and paste it as its shows an error. It's from a Russian MG forum.
 

·
Registered
Joined
·
11,876 Posts
Check you have not left anything disconnected and you could also try removing the positive terminal of the battery for a while and then re connect and see if it sorts itself out.
 

·
Registered
Joined
·
36,397 Posts
The Roewe service manual can be found by googling Roewe 350 service manual.

Cant seem to copy the link and paste it as its shows an error. It's from a Russian MG forum.
Wow, the "Russian user manual" story goes right back to the days when MGR were still trading.

At best IIRC there was an Intellectual Property (IP) issue. At worst I seem to remember following a link there is good faith and my antivirus informed me of all kinds of viruses. If only we had a real life thing like that today...
 
1 - 13 of 13 Posts
Top