MG-Rover.org Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
Can any one advise if not am scraping this car I only use it on weekends mechanics here are clue less
When I drive the car with part open thermostat temp stays at 70 when driving when I put on the fun to cool the engine when house up to 95 on idle notice half the radiator is cold when fun is off it’s ok what could it be I really had enough if I can’t fix it I we’ll scrap it it’s a shame to see another go to west any advice this problems turned up when I changed the antifrize now some times on I park over night I lose like half lt of coolant some times could it be the water pump has gone and not circulating water to the radiator and the leak 2 thanks
 

·
Registered
mg_tf
Joined
·
652 Posts
Armandio, we need to take it in steps.
Remember the cooling system is closed. If working properly nothing should escape.
There are a few possibilites:
When you changed the coolant do you know how much you put back in? A 1.8 petrol needs about 6.2 litres from memory. If you didn't get that much back in you may still have air in the system. See here: The 75 and ZT Owners Club Forums - View Single Post - Hope its not the head gasket
If you've done a coolant change you will know where the bleed screw is- it's easier to access if you unclip the air filter lid and just swing up and out the way. Do both sides of the heater in the cabin blow hot?

If you filled properly, but you are really losing coolant, it has to be going somewhere!
1. Has the oil level crept up? If not, and oil is clean, that's very good- the head gasket is OK and the coolant isn;t getting int the oil.
2. I haven't had my ZT long, but I know on the TF a failed expansion cap can cause to coolant loss. Hopefully a long term owner will come along and advise on this.
3. Water pumps can fail. Do you know when the timing belt was last changed, and was the water pump done at the same time? Changing belt only can hurt the pump. Unfortunately, small steady losses can evaporate away because the engine is hot before they show.
4. Have you looked for a leak? Look for pink stains dried around the end of hoses. Park the car over something like a big sheet of dry carboard, run til hot, then turn off and watch for a while. Some leaks show when the car is running but others only appear after you turn off- the water pump is nor circulating the coolant which can then get extra hot.
 

·
Registered
Joined
·
62 Posts
Discussion Starter #3
Fixit the leak some Albania sausage mechanic didn’t fix the thermostat joint they way it should be

As for the coolant I out 5lt of antifrize and one with water then it was leaking so keeled adding water now that’s fix the leak am during a flash agen my self

What’s the proper way to do it open the bleeding screw then add slowly coolant with the engine running or of ?

As for the radiator its all hot when I drive and turn on the fan it turned to go half stone cold car it’s like new it’s got all original painted by e professional

I thing it’s the cup cause some times after 5mls drive I open the radiator cup some air comes out some times when fun runs hoses go half sucked in

Cars done nearly 200.000 mls do you have any idea how many mls they can go?
Thanks a lot every one


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
62 Posts
Discussion Starter #4
Heat only blows on left side just e little the rest is ice cold


Sent from my iPhone using Tapatalk
 

·
Registered
mg_tf
Joined
·
652 Posts
Armandio,
If the heater blows hot even just a bit then coolant is reaching the heater matrix, which is good. When one side is cold, it probably means the heater matrix is blocked or clogged on one side.
Fixing that could mean draining the system, removing the matrix and flushing it through.
Then having to refill and bleed the system. I need to fix mine soon as well.
If I was you, I would think about doing this now- it will fix your heater problem, and what you DON'T want to do is bleed your system properly then have to come back and do this all over again to fix the heater.
It will also give you a chance to start the coolant refilling process and bleeding over again, rather than going round in circles.
I think it is possible to flush the matrix in place- from what I'm reading quite a few people have leaks after removing the matrix.
If I find a good "How to" I'll link to it.
 

·
Registered
Joined
·
62 Posts
Discussion Starter #6
Fixed that now car have new problem it’ runes on petrol and gas am losing power it don’t fill the same what’s the normale temperature this cars run at? I left the thermostat on purpose with holes to run better tem on idle go 95 till the fan kicks in when on motor way drops and stays at 67 75
And one last thing
Well the back muffler of the rover 75 diesel 2 engine fit my rover 75 1.8 petrol
 

·
Registered
mg_tf
Joined
·
652 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #9
I changed the oil today new filter and new spark plugs and boy what a difference car it’s perfect now accept the back muffler that has few holes I blocked them with that special glow it passed mot with out even go to the mot 😂 yep welcome to Albania I still need a new one here in Albania it’s like impossible finding parts as I brought this car back in 2004 when I was dealing in uk 😂
I only drive it on weekends now
Just wondering if the back muffle of the rover 75 diesel we’ll fit my rover 75 1.8 petrol as I have fund one in perfect condition here, thanks a lot for your feed back Advices for keeping this car for another few years on the road,
Am returning to uk we’ll look for another rover 75 that has the lowest mls or even e brand new one if any one have it am willing to pay top offer for the lowest mls and perfect condition thanks a lot god save the queen,
 
1 - 9 of 9 Posts
Top