MG-Rover.org Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Drivers window on my Rover 800 worked intermitently and then decided to go down but never come back up again, took it to quto electrics and (nice man got my window up) and said it was the switch pad that wasn't working, i've fitted a new switch pad and it still won't work. Motor is fine and everything else on the pad works including mirrors but nothing for my drivers window. It makes a single clicking noise when you press the button but won't move at all. It's irritating not having a working drivers window.

Also the wipers work fine on constant but on intermittant they go up the window but kinda give up halfway back down, will move again after that but never have enough energy to get back down, was told it could be either a new motor or a capacitor burnt out. Tried to get a new motor but been told they are obsolete now. Any ideas where i can get one.

LQ
 
R

·
Guest
Joined
·
0 Posts
I would start with the old, standard Rover 800 problem - the fusebox to the right of the steering column under the dash. The joints go dry and crack up - resoldering them usually cures the problems.

The fusebox is easy enough to remove and the whole job should take under an hour (but you may need a fairly hefty soldering iron to do the job as some of the jonts are quite large).
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks. Must admit i never once thought of the fuses at all, take it that you can't just put another fuse in. To be honest I've never even looked at the fusebox or what's in there.
 

·
Registered
rover_800
Joined
·
36 Posts
It is the fusebox joints themselves that are at fault. You need to take the fusebox out (Quite easy-all multiplugs), remove the back and resolder all the joints just to be sure. Cures 95% of 800 electrical problems!! If the wiper motor turns out to be faulty, there are plenty of good second hand ones about.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
both the wipers and drivers window playing up. Think i'll have to send her off somewhere if there's soldering to be done *giggles at the thought of me with a soldering iron*, i have checked the fuses themselves and all of them are fine, took door panel off and checked the connections and they are all okay. All other windows and mirrors working okay just the drivers one not doing anything, apart from a clunky clicking noise when you press the up button, but i can't get to the window motor itself as it's behind the metal panel of the door, to have a looky at that.

I'll see if one of the lads at my local scrap yard can pull a wiper motor off, will it have to be off another 800 or would any rover wiper motor fit.
 
R

·
Guest
Joined
·
0 Posts
There is also a possibility that some of the wiring may be damaged. Where the wiring loom goes from the car body into the door, you have a flexible section which is convered by a rubber tube (open the door and look by the hinges).

The constant flexing can cause a wire or two to break and only make intermittent connections - this is what has happened on my 800 with the mirrors and speaker. You need to remove the door trim amd replace the sections of suspect wiring - I will when we have a decent weekend weather-wise.

I'd try the fusebox first as it's quicker!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Checked what wiring i can see and that all looks okay, okay I know it's been said it's quite easy and all multi plugs (not that i have any clue what that actually means) and have to take the fuse box out and the back off but don't actually know what i'd be looking at or what to look for, please bear this in mind, I'm the typical blonde woman, i can take the door panel off which to me is a big victory, and i did find all four fuse boxes in the car.
So sorry if i'm slow with this but it would be nice to have my baby working properly again.
 

·
Registered
other_rover
Joined
·
2,435 Posts
I had the problem with the drivers window on mine.

I took the fuse box of and resoldered it (easy job) this didn't work so i took the control panel apart (for the windows on the drivers side) and resoldered its internal (that appeared to have been done before as board had been burnt with soldering iron).

If you are confident with the iron (as the gaps are very small on some of contact on fuse board) then its easy peasy.

Mine turned out to be the window control switches. worked fine after solder.
 
R

·
Guest
Joined
·
0 Posts
Do you have a friend of either gender who is handy with a spanner, screwdriver and soldering iron?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
none that i'd trust with my car, lol. I've never used a soldering iron before but i'm okay with spanner and screwdrivers, just don't know what I'm looking at or what things are.
 

·
Registered
other_rover
Joined
·
2,435 Posts
If you have kids ask them to take it to school and get the electronics teacher to resolder them :D
 

·
Registered
Joined
·
29 Posts
Hi all
Wondering if anyone remembers seeing a reply on this subject in another post where the poster said that, due to his knacked window/fusebox/controller he couldn't get the cd player (standard) to work... I think I saw it but can't remember where

Cheers
Gaz
 

·
Registered
rover_25
Joined
·
18 Posts
Could be an easier fix than that - you tried disconnecting the battery for 30 seconds and then re-connecting?

The windows on my old vitesse used to do this from time to time and it always solved it. Most of the electrics on the 800 are controlled by an ecu that sits under the passenger seat. Every now and again it goes nuts! Basically power cycling it resets it and often solves sill problems. Nice easy and hopefully free fix to try!

HTH
Jon
 
R

·
Guest
Joined
·
0 Posts
targed said:
Could be an easier fix than that - you tried disconnecting the battery for 30 seconds and then re-connecting?

The windows on my old vitesse used to do this from time to time and it always solved it. Most of the electrics on the 800 are controlled by an ecu that sits under the passenger seat. Every now and again it goes nuts! Basically power cycling it resets it and often solves sill problems. Nice easy and hopefully free fix to try!

HTH
Jon
It usually goes nuts because of dodgy solder joints! Two out of our 5 800s have done just what you described, cured but soldering the fusebox.
 

·
Registered
Joined
·
1 Posts
Rover 8oo window fault

I had a similar problem on a P reg 820si. The windows/sunroof and radio would stop working sometimes and other times would work. The problem in this case was weak joints in the fuse box by the driver's footwell. A chpa resoldered them and all was fine then.
 
1 - 18 of 18 Posts
Top