MG-Rover.org Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter · #1 · (Edited)
Hi,

I have serached and found many threads regarding wind noise in 75s and other models however I cant seem to understand the proposed solutions.

My rover 75 makes this rattling noise at speeds higher than 130 km/h and it gets louder with speed, sometimes i spray water and use the windscreen wipers to soften the noise, however it comes back straight after that.
I am 99% sure this noise comes from the windscreen but dont know how to solve it.

Can anyone provide me with any insight into thi issue?

thx
 

·
Registered
Joined
·
4,687 Posts
This might sound nuts, but..


Try folding down the sun visors. My CDT auto has a beaut of an annoying 'fizzz' coming from the drivers side one, with no apparent regularity. move the visor, it stops.


CAM
 

·
Registered
Joined
·
514 Posts
Are you sure this problem is not you wipers vibrating, I had a similar problem on a Fiat people carrier and due to the long length of the wipers found that after I went above say 70 the vibration would be louder, it then obviously stopped when the winscreen was washed.
My 75 does not suffer this but I notice a new set of wiper I fitted recently had a spoiler on the drivers side.

Stubie
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #6 ·
my one also has a spolier, it could be that cause it stops when the winscreen is washed and then caomes back again later. I will remove these today since it shouldnt rain and see what happens

cheers
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #7 ·
Thanks to all your comments I have pint pointed the problem. This noise comes from the top seal of the windscreen wiper, this is why when I spray water the noise stops. Now I need to know how to propery seal the widnscreen, does ayone know which product to use?
thanks
 

·
Registered
rover_75
Joined
·
29 Posts
Rattle from windscreen

I have a post about exactly the same problem on my 75 V6. It is NOT a blade problem!! I am getting close to replacing the windscreen. I agree it is a windscreen sealing problem. I have one more crazy idea and if it works I will let you know. I had the problem over two years ago and it went when I used Clearalex powder windscreen washer additive. Although it dissolves, it still comes out powdery (leaving streaks on the car paint!!). My theory is that the Clearalex blocked the small cavity which is allowing air through at high speed.

My 'sound' is definately from the bottom of the windscreen. If all fails I will ley you know. My 5lb hammer may be getting to know my windscreen very soon!!!!!!
 

·
Registered
rover_75
Joined
·
29 Posts
I am pleased to say that Clearalex seems to have done the trick!! I guess it blocked the hole - it certainly leaves a lot of powdery residue all over the paint work. Glasd not to have to use it any longer - I used double stength to be fair - blocked one of the nozzles but fine wire cleared it. Relief at last!!!!
 
1 - 10 of 10 Posts
Top