MG-Rover.org Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
Hi again guys !!! A couple of quick questions. What is the mileage that the plugs, timming belt and pollen filter should be changed. Also where is the fuel filter in the car before I start looking for it. Many thanks, Robin.
 

·
Registered
Joined
·
1,341 Posts
Timing Belts are 6 years or 90,000 miles, whichever is sooner.

Fuel filter, under the rear passenger seat, nearside.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #4 ·
Thanks Tatts. What should I be looking for that holds the back seat down ? also for the fuel filter (2001 car) is it a banjo or hoseclip connection or is it a special tool like the Vauxhalls and Fords etc. R.
 

·
Registered
Joined
·
616 Posts
The back seat is held down by the underseat wires slotting into body clips. Lift the front edge upwards and look underneath with a torch and all should be clear. If you search this site under fuel filter separation you will find plenty of information on fitment and removal. The main thing is to ensure that you have the security clip fitted if its the later type unit. The filter itself does not have a specified change interval, so I assume it is designed to last for vehicle life.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #6 ·
Timming Belt

Hi and thanks again for all your replies. I have been quoted 5 hours @ £35.00 (inc vat) to replace the belts but he will only use genuine Rover belts as he has had problems with after market ones !!!! I supply the belts. Now i have had the car a few days and done 300 miles drives and runs great as I guess it should at 41k. The temp guage sits at normal and never moves !!! IE Half way on the guage. I soon will be towing a caravan I wonder if this temp will change ? I did get a yellow warning light today !!! was a triangle with a anti-closkwise arrow but not having a owners manual yet i have no idea but its ok now...Any ideas......All the under bonnet levels are all ok.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #7 ·
Coolant Loss

As I said in my last message car is running perfect. Temp gauge stays normal all the time never really moves, no erratic running, heater etc all fine but i find I had to top up the header tank by approx 1 litre. Level just above the fins in the tank. This morning I re-checked it and took about 500ml and no signs of coolant leaks. Can I asume I have bought a car with a head gasket problem ? or does it need bleed in some way. R.
 

·
Registered
Joined
·
1,505 Posts
Once a 75/MG ZT has warmed the temp gauge will ALWAYS remain at the mid mark or a whisker under. If it changes from that in either direction SOMETHING IS GOING WRONG AND SHOULD BE INVESTIGATED ASAP.
Even towing should not make any difference as the cooling fan will increase speed and operate more frequently to keep the temp at the midpoint.

I think its possible that you are overfilling the rad a little causing the excess to blow off and make you think you are loosing water. The water level marks are a little hard to see but check the water level carefully or even do not top up next time too see if the level falls any further.

Head gasket failure is not common on a V6 so really is the last thing to consider. If after checking the levels against the marks you still think you loosing water try a search on this forum under 'water leaks' and you should come up with the most likely causes.

Hope this helps.
 

·
Registered
Joined
·
1,505 Posts
The warning light you saw would appear to be for Traction Control.

According to my handbook the light flashes while the traction control is operating.

It should also appear for about three seconds as a bulb check when you switch on and all thetime if you switch off the traction control manually.

If you have not switched it off and the light remains on then there is a fault.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #10 ·
Thanks David for your replys. Re the coolant loss I will do as you say and keep and eye on it over the next few days. Re the traction control !!! I had no idea I had it !!!! Unlike my last car Volvo 850 had a separate switch. Has the Rover got a switch ? Robin.
 

·
Registered
Joined
·
1,505 Posts
Going by what the book said about the warning light I would say yes to the switch and would guess that its with the other switches in the middle of the dash - probably bottom row middle but as I say its a guess. And I've put the handbook back in the car so cant check right now.

Will have another look in the book in the morning.

What model have you got by the way. Know its a 2.5 but Club, Conn ??
 
1 - 12 of 12 Posts
Top