MG-Rover.org Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi guys i have a rover 75 1.8 petrol
Recently done a head gasket run perfect for 1000mls then constant misfiring returned it has new spark plugs it misfiring on both petrol and lpg gas it has new coils as well car shakes while driving stalls when turn the wheel left or right what should it be done to save it from scrap morning starts perfect for a minute no misfiring them boom starts again cant even hold to keep running if i dont give it a bit of gas till it switches to lpg
 

·
Registered
rover_75
Joined
·
128 Posts
Hi I have a rover 75 1.8 with lpg too . I also did the head gasket ages back with a multi layered steel one which failed about 2000 miles in the engine became hydro locked water from the cooling system getting in . So check your coolant levels . But I have had the car many years and I think I know what’s wrong with it .
Do you keep the car outside ? With all this rain I think the bulkhead between the engine bay and below the windscreen has filled with water . This compartment behind the battery box can flood due to crap drains getting blocked . Is the lpg landi renzo ? They piggyback there ecu for running the lpg side onto the original rover ecu if u look you will see if there is water in it will make your car backfire do alsorts . Hope this helps I ended up forcing some hosepipe down the drains to hold them open so it wouldn’t flood if you want to ring me be happy to help pm me
If u need to
 

·
Registered
Joined
·
10 Posts
Don't be concerned about the steering behaviour. It's just the power steering load on an engine that's barely running. When you fix the underlying problem, the steering will come good too.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Hi I have a rover 75 1.8 with lpg too . I also did the head gasket ages back with a multi layered steel one which failed about 2000 miles in the engine became hydro locked water from the cooling system getting in . So check your coolant levels . But I have had the car many years and I think I know what’s wrong with it .
Do you keep the car outside ? With all this rain I think the bulkhead between the engine bay and below the windscreen has filled with water . This compartment behind the battery box can flood due to crap drains getting blocked . Is the lpg landi renzo ? They piggyback there ecu for running the lpg side onto the original rover ecu if u look you will see if there is water in it will make your car backfire do alsorts . Hope this helps I ended up forcing some hosepipe down the drains to hold them open so it wouldn’t flood if you want to ring me be happy to help pm me
If u need to

Ordered new coil pack no need today finally find out the problem when the car runs out of petrol to zero and it got to lpg no back fire nothing car runs perfect no problem if I switch to peterol boom rough idle misfiring and like 5lt of petrol goes f know where in 15mls drive take out the spark plugs first cylinder running a lot rich all in black so thats where my problem is what am i looking at a leaking fuel injector or a failed coil packs ?
 

·
Registered
rover_75
Joined
·
128 Posts
Ordered new coil pack no need today finally find out the problem when the car runs out of petrol to zero and it got to lpg no back fire nothing car runs perfect no problem if I switch to peterol boom rough idle misfiring and like 5lt of petrol goes f know where in 15mls drive take out the spark plugs first cylinder running a lot rich all in black so thats where my problem is what am i looking at a leaking fuel injector or a failed coil packs ?
 

·
Registered
rover_75
Joined
·
128 Posts
Ordered new coil pack no need today finally find out the problem when the car runs out of petrol to zero and it got to lpg no back fire nothing car runs perfect no problem if I switch to peterol boom rough idle misfiring and like 5lt of petrol goes f know where in 15mls drive take out the spark plugs first cylinder running a lot rich all in black so thats where my problem is what am i looking at a leaking fuel injector or a failed coil packs ?
.
Hi , it’s worth looking under the inlet manifold side on mine the lpg goes in there and it had been altered and there were pipes attached into the inlet manfold like a thin 6 mm poly set of pipes one one mine had worn though the wear was where they had cabled tied the pipes together . I take it it’s the factory fitted lpg that rover did ?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
No my8 its a modified one on log runs good its on petrol am having problem any way sorted out i start tje car on petrol i get it uo to temp switch over to lpg and tane the pump fuse of problem solved
 
1 - 7 of 7 Posts
Top