MG-Rover.org Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
3 weeks ago my cousin had a small accident with the car and the back-left tyre blew up. He then replaced with the spare but the next morning the spare one was flat as well.

He took the car to Quick Fit and they replaced the spare and the damaged tyres with brand new one - £75, plus wheel alignement.

Yesterday the new tyre on the same side went flat as well.

A bloke at RAC told me the reason may be the wheel is damaged and probably a bit of metal it's sticking out and damaging tyres.

Tomorow i have to change to the new spare tyre and go to quickfit again.

Can someone give me an advice?

Cheers
 

·
Registered
Joined
·
4,687 Posts
By what I can read the only commonality is the wheel, so it would appear to be damaged, a 'flat spot' causing loss of seal and air escape.

However, worth checking, but they did replace the valve when they replaced the tyres didn't they? You may well have paid for it, but did they actually replace it? Seen them 'forget' to do this!! If its a duff valve then that could be your prob!


CAM
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Hi thanks for reply.

I don't know what they did, I wasn't there and my cousin speaks very little english.

I have to go myself to that place and ask them.

This people like to rip off and cheat.
 

·
Registered
rover_45
Joined
·
11,619 Posts
All Kwick Fits are rubbish. I have yet to hear a good word about any of them. In the past when I have used them I have seen the following,

Break clamps left on,
Exhaust bent to fit rather then using the correct one,
Tyres incorrectly seated on rims and so on,

As CAM4V said I would suspect the rim of the wheel.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
i'll go and have a word with them.

the thing is that where i come from things are done so differently. Mechanics still rip off people, but some things are done with certain security, but here i don't know where to go to fix those things.

I bought the car a year ago and the back windows don't open, never did. as if a security system against children has been installed and never removed.

It's frustating.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top