MG-Rover.org Forums banner
1 - 5 of 5 Posts

·
Registered
rover_25
Joined
·
17 Posts
Discussion Starter · #1 ·
Hoping someone can help me here. Just aquired Rover 25 and found rear washer not working.Found tubing cut inside grrommet at n/s hinge. Repaired and now ok.Washer pump sounds good and also jet of water from end of pipe but when connected to rear washer inlet on rear wash wipe no water comes out of the jets .Lifted jet cover to expose nipple but no water from this either. Can anyone please help?
 

·
Registered
Joined
·
186 Posts
Hoping someone can help me here. Just aquired Rover 25 and found rear washer not working.Found tubing cut inside grrommet at n/s hinge. Repaired and now ok.Washer pump sounds good and also jet of water from end of pipe but when connected to rear washer inlet on rear wash wipe no water comes out of the jets .Lifted jet cover to expose nipple but no water from this either. Can anyone please help?
There's an in-line one-way valve at the rear window end of the tube which is basically a double male connector with a ball bearing and a spring inside it - check this hasn't stuck shut and is blocking the water flow..... and dont be tempted to remove the ball bearing or replace the valve as the water then flows back down the tube and takes ages to come through when you activate the washer....
 

·
Registered
rover_25
Joined
·
17 Posts
Discussion Starter · #3 · (Edited)
Thank you for advice. Yes the non return valve connector is in place and the water comes out of this connector no problem. When its connected to the Rear wash/wipe connector no water comes out of the washer nipple hidden under the jet lift up flap on the wiper.
 

·
Registered
rover_25
Joined
·
17 Posts
Discussion Starter · #5 ·
Thank you

Sorry for delay in saying thanks for advice. Will have to find an airline to use. Thinking maybe tyre pressure hose will fit the large nipple below the lift up jets of the rear screen. Thanks again.
 
1 - 5 of 5 Posts
Top