MG-Rover.org Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
When pressing accelerator the engine sounds rough for the first half inch of travel on the accelerator then sounds fine after that. Car drives well, engine sounds normal and smooth after that half inch. Same hot or cold. anyone got any ideas?
 

·
Registered
rover_45
Joined
·
282 Posts
Your description is far too vague to give a useful answer; it could be any one of many things, for example are there any loose metal shields on the exhaust manifold? Additionally it might be loose baffles in the exhaust silencer or even weak/broken engine stays/mountings. Another common cause is loose/failing HT leads or other loose electrical connectors. You might even only be firing on three cylinders. As you can see I could go on for ages....

Can you add more detail; is the engine down on power? Are there any petrol/exhaust odours, any tinny metallic noises or anything else that sounds odd? Does the roughness only occur after the engine is started or does it occur on every pick-up from idling?
 

·
Registered
Joined
·
254 Posts
try cleaning out your throttle body with carb cleaner, bit of muck in there might not be helping. Is it definatly 8v as i thought they were all 16v?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
Does not seem to be any loss of power, unusual smells or tinny metallic sounds. Noise seems to be from engine not from anything loose vibrating and is everytime on accelerating from idle. Idle is smooth and regular.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
kev25v6 said:
try cleaning out your throttle body with carb cleaner, bit of muck in there might not be helping. Is it definatly 8v as i thought they were all 16v?
Yes definitely 8 valve
 

·
Registered
Joined
·
17,398 Posts
You need to elaborate on this noise with what it sounds like and is it rev dependent? From what area does it come from? Does it do it stationary, moving or both? Have you listened to it under the hood?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
I am aware of noise while stationary and moving, not so evident at higher speeds. I will try listening under bonnet tomorrow when i've got someone to press accelerator. It's difficult to describe noise, it's not high pitched but a low rough sound which goes as soon as i'm past that initial half inch.
 

·
Registered
Joined
·
17,398 Posts
No need to get someone to press the accelerator. Just push the throttle down with your finger. It's the thing on the end of the inlet manifold just incase you're not sure.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
Is that anywhere near the water bottle for the windscreen washers? Thats about my limit working under the bonnet, oh and I know where the dipstick is.
 

·
Registered
Joined
·
254 Posts
follow from your air filter box and the throttle body will be on the end of it. There will be a cable on the throttle body, this is the accelerator cable. Pull this and the car will rev, becarfull of the fans, belts etc moving in the engine bay, it may also be hot in there so dont burn yourself.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
Thanks, i'll give it a go and hopefully i'll get an idea of where the noise is coming from.
 
1 - 11 of 11 Posts
Top