MG-Rover.org Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
rattling top end rover 400 k series PLEASE HELP

hi there ok been driving around in my rover 400 when i realised i had an oil leak got home ok checked the car in the morning big pool of oil underneath so i jacked it up and found a hole in the sump which i repaired the car seemed fine then a couple of days ago the top end started to rattle so i removed the rocker box cover to investigate and i ran it no oil anywhere to be seen top end dry think its the oil pump or strainer blocked also are they hydralic lifters? plenty of oil in engine anyone had simular problems to give me some advice thanks
 

·
Registered
Joined
·
48 Posts
im having thesamewith mine at the moment. start it in the morning and atop end tapping and reducedpower. goesafter about 10 mins. havenot openedit up yet. reckon it may be an oil pressure issue. there ore hydraulictappets in these engines. will post when i have more info
 

·
Never forgotten
Joined
·
16,723 Posts
Assuming that the oil light goes out - you have oil pressure in the cylinder block. If the top end is dry, it means that the oil way to the head is blocked - I think it has a 2 mm restrictor.

Probably means taking the head off to cure it I'm afraid.

A top end rattle that goes away shortly after starting is caused by a leaking tappet. This is caused by contamination of its internal ball valve. It is worth flushing the oil system, but you may end up having to replace the faulty one.
 
1 - 4 of 4 Posts
Top