MG-Rover.org Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
had a leak on the radiator put in some radweld was ok for a while but leaked again so put in some more now its not starting straight away it always did, and has cut outa few times sounds abit ruff aswell any ideas???
 

·
Registered
Joined
·
2,192 Posts
elaine214 said:
had a leak on the radiator put in some radweld was ok for a while but leaked again so put in some more now its not starting straight away it always did, and has cut outa few times sounds abit ruff aswell any ideas???
Its not advisable to use radweld in the k series, waterways are very narrow in this engine.
 

·
Mmmm....Rover..
Joined
·
10,426 Posts
Because of the way Radweld works (blocks small holes) it could block the narrow waterways and passages in the engine, you would be very unlucky if this happened but the possibility exists.

The cooling system on the K series engine must be always well maintained as the system has a small total amount of coolant. Any leaks can lead to much more expensive problems.

The better solution would be a new radiator and a flush of the cooling system to rid the Radweld.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
ok thanks for that..How much would a new radiator be and would it cause the cars starting problems..
 

·
Mmmm....Rover..
Joined
·
10,426 Posts
I would doubt that the two problems are related.

When was the car last serviced?

Spark plugs, plug leads, distributor cap and rotor arm would be high on the list for the starting problem.

I'm assuming you have a 214 without aircon?

www.adrad.co.uk list the radiator at £30 + VAT + delivery.

Dealer price for the genuine item is about £118 + VAT.
 
1 - 8 of 8 Posts
Top