MG-Rover.org Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
i have a 1997 1.4 16v rover 214 (bubble shape). i am having to fill the expansion tank for the radiator every second day. i dont know where it is leaking from and i have tried barrs leaks etc to no avail. could anyone tell me where to sart with this. when i am idling after 10-15 mins the expansion tank seems to boil over like a kettle.it makes a terrible gurgling/suction noise from the expansion tank the car does not overheat. (not given it the chance to) i fitted a new radiator myself and i am pretty sure there are no loose connections on it.

can anyone help me?
 

·
Registered
Joined
·
7,068 Posts
Have you replaced the coolent cap; they can fail and thus boil. The reason for the boiling is pressure is lost, the cap only costs a few pounds and could fix it all!
 

·
Never forgotten
Joined
·
16,723 Posts
You urgently need to trace and cure the leak or you will soon have no head gasket. In fact, this may now be your problem.

If the engine boils up that quickly, it is suggesting that you have an air lock. Does the heater blow hot? If not, then the system will need bleeding. If the air lock problem keeps coming back, it could well be that the head gasket is now leaking gas into the coolant.

If the heater is still blowing hot, then an air lock is not your problem and replacing the cap would be a good first move.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
thanks guys. the heater blows hot then blows cold when it needs water. would it be ok to get a cap from ebay?
 

·
Registered
Joined
·
8,693 Posts
thanks guys. the heater blows hot then blows cold when it needs water. would it be ok to get a cap from ebay?
yes, they sell OE caps on there, but tbh, id rather find one local, as it needs replacing asap, as like diesel says, the HG will wave bye bye if its boiling up so fast!

where are you based?
 

·
Registered
Joined
·
1 Posts
i am having same sort of issue with my Streetwise 1.4 (K series engine).... can any one help please?
it started off with the heater blowing hot & cold, then i had a sudden one off over-heat. now the temp gauge is normal but expansion tank glugs like crazy & the heater blows hot & cold. I did the head gasket myself 3 or 4 thousand miles ago. Any ideas please?
 
1 - 7 of 7 Posts
Top