MG-Rover.org Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
843 Posts
Discussion Starter · #1 ·
i just fitted a new air filter as my old one was black but now i seem to be lacking power,ive heard that unipart filters are rubbish,could this be the cause of my problems?

i alos fitted new plugs but after i noticed the power loss i put the old ones back in and it did help a bit but not a lot.with the new plugs i did notice that it was a smoother drive all round,espcially pulling away but there was a definate loss of power.i noticed on the old plugs that the gaps were different and they ranged from 1mm down to 0.50mm,there are the same make/model plug so i assume they have been altered manualy,what could be the reason if any for this?

ive read a few times on this forum that there is somtimes a problem with the top the the ht lead not sitting properly on top of the plug as the lead does move up and down through the rubber housing.is it worth pulling the contact right though the housing and thenconnecting it to the plug then sliding the housing back on?
 

·
Registered
Joined
·
25,606 Posts
Were all the gaps on the new plugs correct? Were all the leads on in the right places? Unipart filters are fine.
 

·
Registered
Joined
·
843 Posts
Discussion Starter · #3 ·
yeah the gaps on the new plugs were fine,the ht lead are in correct order although 1 of them had a 2 splits on the long rubber housing that sits over the plug.im not sure if it was there b4 i changed the plugs or if i did it,it does look as though its been done recently.could this be my problem?
 

·
Registered
Joined
·
17,398 Posts
jay27 said:
yeah the gaps on the new plugs were fine,the ht lead are in correct order although 1 of them had a 2 splits on the long rubber housing that sits over the plug.im not sure if it was there b4 i changed the plugs or if i did it,it does look as though its been done recently.could this be my problem?
Is the connector exposed through the split? Either way I would change it. There's a LOT of power going through those leads and any break in the insulation can cause arcing. It's a good opportunity to change all the leads.
 
1 - 5 of 5 Posts
Top