MG-Rover.org Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi Folks,
Could anyone please tell me the most likely problem with my oil temp guage. Checked the oil level and its fine, but not showing a reading on the guage itself in the car. What could be the cause of this and how can I fix it??? Please note I am a girlie and not too up on these sorts of problems.
 

·
Registered
Joined
·
2,603 Posts
F or TF? Are the dials silver?

Its one of four things I suspect (although am happy to be proved wrong).

The sender unit is broken

The plug on the back of the gauge has come off (unlikely but possible if someone has been messing around with the Head unit and tugged the loom)

The needle is sticky - does tapping it when you have been for a reasonable trip cause it to move?

Or the gauge itslef has gone kaputt.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Ok thanks for all the replies, another question:-
Is there a way to test the guage itself, to see if that is broken ? also, where is the sender unit located?.......... you see folks I am a bit of a numpty!!!!! and I have no manual. If anyone has a spare that I could buy, it would be appreciated for an MGF VVC "T" Reg!!!!
 

·
Registered
Joined
·
14,789 Posts
Maxine on here had the same problem on her F, it turned out to be the sensor, so don't rule that end out. :)
 

·
Registered
Joined
·
30 Posts
I also have this problem with the missus' new car (brilliant- drive it more than her but can say 'it's purple, it's the girlfriend's...' No temp showing on our guage, level's okay, reckon it's urgent?

Dave.
 

·
Registered
Joined
·
14,789 Posts
The Black Baron said:
I also have this problem with the missus' new car (brilliant- drive it more than her but can say 'it's purple, it's the girlfriend's...' No temp showing on our guage, level's okay, reckon it's urgent?

Dave.
Well i'd get it checked out, as you want to know if/when it chutes up to the dangerous zone.
 

·
Registered
Joined
·
224 Posts
Think of it on the good side....... At least youll never worry about the needle going into the red lol

check the plugs, did it just go dead or did it flicker on and off?
 

·
Registered
Joined
·
2,220 Posts
Raven 13 said:
Hi Folks,
Could anyone please tell me the most likely problem with my oil temp guage. Checked the oil level and its fine, but not showing a reading on the guage itself in the car. What could be the cause of this and how can I fix it??? Please note I am a girlie and not too up on these sorts of problems.
It's oil temperature, not oil level, therefore will not show a 'level' until you warm the car up....
 
1 - 10 of 10 Posts
Top