MG-Rover.org Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi Folks,

I feel something of an imposter - I do not actually own a Rover yet (although my Father does have a 1968 MGB Roadster !!!).

I am in the process of buying a Rover 75 2.0L CDTi Connoisseur SE in Gold 2003/03.

I have gone over the car quite thoroughly and we have had a nice test drive. The car has done 91k miles but has a full PLC/Lease service history at all the suggested intervals with a printout of all works / parts replaced etc.

The last service was 400 miles ago and all of the fluids are nice and at the right levels. But being used to petrol cars (Lexus LS400) the oil on the dipstick looks a little black (?). There is almost nothing to see from the exhaust and the engine is just so very smooth and quiet - is it really a diesel.

Just 3 faults

1. Key fob doesn't seem to operate the central locking but the key in the lock does- hopefully just need new batteries ?

2. Missing CD magazine for the changer in the glove box - ebay ?

3. Low line Sat nav doesn't seem to operate - could be unit in glove box or maybe CD itself ?

Whatever - just wanted to drop in and say "hello" and introduce what will hopefully be my car and the source of many of the questions I ask the experts on here. I am a family man with a wife and 2 lovely children.

I have no doubt that this will become another one of my obsessions, just like shooting, and I will probably shift between this site and www.airgunbbs.com where there is another community of friendly and like mined people keen to help each other out with advice and friendly chat

I wish you all the best and look forward to chatting with many of you soon.

Phillip.
 
1 - 1 of 1 Posts
Top