MG-Rover.org Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1 (Edited)
I've just installed TOAF on the old laptop (W10/64).

First I soldered pins 7&8 together in my OBD cable, and got TOAF connected straight away.

Unfortunately, however, I have some problems:

1. When scanning the car, it worked first time, but when I tried to do it again, TOAF froze;

2. when I click the BCU button in TOAF, it tells me the BCU isn't present… anybody know what to do now?

I could try a different cable driver, I suppose, but I tend to think, as it worked the first time, it's probably not a driver problem?

I've tried TOAF 0.5.00.43 and 0.5.00.51.

Thanks...

134676
 

·
Registered
Joined
·
104 Posts
Discussion Starter #2
Well, after exhaustive testing, it turned out to be the poxy cable.

If you're buying one of the cheapo ones on eBay, get one of the blue ones, NOT the black one.

And don't forget to bridge pins 7 & 8
 

·
Registered
rover_75_tourer
Joined
·
4 Posts
I get this connection error and have tried two different cables, one that already has pins 7 & 8 bridged. I need to find a fault with the airbags and I just don't seem to get anywhere with this connection problem.

Could you offer any advice please?
 

·
Registered
Joined
·
104 Posts
Discussion Starter #4
Ummm… well my limited experience with TOAF, and rather more with computers suggests two possibilities:

  • Bad cable – are they the black ones from eBay, or blue?
  • Which COM port has Windows assigned to it – I think TOAF can only handle up to COM4?
Say if you don’t know what (2) means ;)
 

·
Registered
rover_75_tourer
Joined
·
4 Posts
Thanks for your reply. I can now connect to TOAF and it is displaying all of the modules with the exception of the SRS.
Does anyone know what the problem could be? It seems strange that it cannot find the SRS module.
 

·
Registered
Joined
·
104 Posts
Discussion Starter #6
It seems strange that it cannot find the SRS module.
Somebody more knowledgable will probably be along, but I seem to remember there's an earlier and later version of the SRS, and TOAF doesn't recognise the newer one...?
 

·
Registered
Joined
·
104 Posts
Discussion Starter #8
From a sainted member of another forum:

"Standard Toaf will only read the airbags up until about 2002 and then Rover started using Autoliv. As your car is a later model you have to, if you haven't already tried, use the SRS Autoliv Tool available from the Toaf website. Another complication is that the tool requires Vista or higher to run it, but it works."

Don't know anything about that, but the guy in question is pretty experienced with TOAF.
 
1 - 8 of 8 Posts
Top