MG-Rover.org Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
Everytime my ZS is moving, there is a clicking sound coming from the front portion of the car. It sounds like the slight clicking made when rotating your mouse wheel. I thought I had it sussed when I tightened up the bracket holding the air con hose against the side of the engine, however, this didn't do it. I've taken it back to the dealer, and they've tried replacing some of the relays, but still to no avail. DO any of you guys have any idea whats going on?

It starts when I change into 2nd for the first time on any journey, and will continue clicking, and occassionally start loud buzzing, until I either depress the brake or clutch. I'm stumped, Brindley are stumped, so does anyone have any ideas??
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #4 ·
It sounds like its coming from the centre of the dash, but having taken it back to the dealer to look at, they had a guess that it might be the CV joint, but pretty much said that finding it would take too long, and they didn't really want to do it.
VIS valves, where about would they be located?
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #7 ·
M4RTIN said:
well i hope you never visit that dealer ever ever again
Strangely enough, that was Brindley in Wolverhampton, and as Stour Valley gave me the worst service ever when I bought my 25 from them a few years back, I guess the next option is the Summit Garage in Himley.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #8 ·
Its not necassarily when cornering, its pretty much constant from when you pull off, to eityher when you put the brakes or clutch on, or when you stop.
 
1 - 8 of 8 Posts
Top