MG-Rover.org Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter · #1 ·
Hey guys, Just fitted a boost gauge and controller, already have a tunit box for fuelling. Having tested the car now on a quiet straight road there seems to be some issues. Basically then car pulls really well up to 20psi-ish then the turbo just stops running. In 5th gear I can only get to 85mph then the accelaration just stops. I pressume this is a really easy fix! Do I turn the boost down? Up the fueling more? Both? Get a remap?

Cheers for any help
 

·
Registered
Joined
·
551 Posts
Don't know if i'm totally right in saying this as i haven't got the sdi version of this engine but it sounds as though your hitting boost cut. I also didn't think that the tunit box was meant for the sdi engine but for the later spec engines in the 25/45/ZR/ZS. From what i've heard you'll either need to get a roverron tuning box which will also help with the boost cut i believe, or get it chipped.

Also check your intercooler pipes for splits just in case it's that simple.

Hope i'm right and hope this helps.

Phil.
 

·
Registered
Joined
·
25,606 Posts
If the cut in power co-incides with the turbo hitting 19psi then I'd be fairly certain it was boost cut. When the boost hits this level the ECU reduces the fueling as a safety measure.
 

·
Registered
Joined
·
865 Posts
JUst as an aside how much on the standard turbo is safe?? I am running 20 psi and dont seem to have had any problems but wouldnt want to risk anything as i do 500 miles a week.
 

·
Registered
Joined
·
551 Posts
Looks like I'll fleabay my tunit then and get a ron box
Done a quick look and i'll correct my self about the tunit boxes only being for 25/45/ZR/ZS spec engines. They do indeed also do them for the SDI engines but you are probably still better off getting one of Rons boxes as it helps with boost cut situation.

Hope all goes well with the tuning.

Phil
 
1 - 8 of 8 Posts
Top