MG-Rover.org Forums banner

1 - 7 of 7 Posts

·
Registered
mg_tf
Joined
·
54 Posts
Discussion Starter #1
Hi, I have a very annoying leak and just can’t find where it’s coming from. It’s dripping from the oil temperature sensor. Obviously it’s not coming from there, but that’s where it’s located, and around the sump. I’ve replaced the water pump as thought it was coming from there, but it still drips. Checked all the pipes coming from the expansion tank, all in good order. Any ideas would be very welcomed
 

·
Registered
mg_tf
Joined
·
35 Posts
Hi, I had the same issues and mine was leaking from the thermostat housing/coolant rail. Replaced the housing and all is sorted
 

·
Registered
Joined
·
3,024 Posts
I had the same problem late last year, and after a search using a mirror on a flexible arm, and a torch, I found an external head gasket leak by the cambelt end of the exhaust manifold.
 

·
Registered
mgf
Joined
·
806 Posts
Hi, I have a very annoying leak and just can’t find where it’s coming from. It’s dripping from the oil temperature sensor. Obviously it’s not coming from there, but that’s where it’s located, and around the sump. I’ve replaced the water pump as thought it was coming from there, but it still drips. Checked all the pipes coming from the expansion tank, all in good order. Any ideas would be very welcomed
I had stainless steel coolant pipes and they leaked at the brackets where welded to the pipes took a while to find. Got new pipes then all ok
 

·
Registered
Joined
·
201 Posts
I had the same problem late last year, and after a search using a mirror on a flexible arm, and a torch, I found an external head gasket leak by the cambelt end of the exhaust manifold.
Snap.

I had this same issue, 4K miles after the HG was replaced.
 

·
Registered
Joined
·
1 Posts
I had the same problem late last year, and after a search using a mirror on a flexible arm, and a torch, I found an external head gasket leak by the cambelt end of the exhaust manifold.
It would appear i have this exact issue, located just above the alternator on the cam-belt side of the engine. Leaking from a seam which i believe to be where the head gasket is. I have only just bought this car and it had its head gasket replaced 1 month ago, with hardly any miles travelled since. How did yours get fixed? Do I need another bloomin' head gasket? Thanks in advance, Danny.
 
1 - 7 of 7 Posts
Top