MG-Rover.org Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Does anyone know the best solution for this problem on MGF? I understand it is a common trait of the (basically) Honda gearbox. Can new detent be fitted? Or does it need a new 'box?

Brian
 

·
Registered
Joined
·
5,647 Posts
Brian Greenwell said:
Does anyone know the best solution for this problem on MGF? I understand it is a common trait of the (basically) Honda gearbox. Can new detent be fitted? Or does it need a new 'box?

Brian
Never heard of this TBH.... The PG1 gearbox gives very few problems as a rule..

The Gearbox mechanism in the `F` is cable operated so I would think its more to do with adjustment than a problem with the gearbox itself!.

Perhaps one of the 2 cables has worked loose and is not fully engaging fifth.......... hence the reason it jumps out!!..
 

·
Registered
Joined
·
17,819 Posts
I have had it happen to me once before on a PG1 gearbox.

But it happened because the oil drainer plug had worked loose and the oil had drained out (very noisy gearbox).

so oil level check a good idea.

Although it is most likely cable adjustment that is required.
 

·
Registered
Joined
·
1,196 Posts
Hi

It's been happening on mine for the last two years. I did talk to a gearbox specialist he said it may be the linkage, never really got around to getting it fixed. Never throght of the oil??

I do remember some reports some time ago & I think it also happens on the Landrovers as well, same box I think.


MikeS
 
1 - 8 of 8 Posts
Top