MG-Rover.org Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi. I am having some problems with my MG F 1.8 mpi 1997. The car has 50k on the clock as I mostly used some week end. She did function well most of the time, however I habe been having some troubles that are beyond my understanding. I close the car with the remote and the alarm light remains on all the time. At the same time the central mirror lights also remain on, and can not switch them off. Rearview mirror becames hot in a short time. Otherwise when I open the car with the beeper and start the engine everything return to normal, alarm light is off, and the car run well. Most intriguing for me. I will be grasteful whether any of the members may suggest what the problem is.
Best
Mike
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
kpainter65,
Thanks for coming in.
The answer is no. This car remains original.
Nineteen years with me. Head gasket failure many years ago, a few hydragas spheres replaced, and that has been all.
Engine run very well and the car drives fiene. But as from as last week end, every time I close her -with the remote- rear mirror lights remain on, and also the red alarm light in the dash remain solid red, not flashing as it did before.
Mike
 

·
Registered
mg_tf
Joined
·
361 Posts
I suspect you may have a problem with the door lock or wiring that goes to it or the Multi Function Unit. The switch for the interior light is in the door lock mechanism, this then goes to the MFU that controls the interior lights and send a signal to the alarm unit. The MFU is easy to replace and you can pick them up for approx. £10. The alternative is to use a multimeter to check what you’re getting from the lock mech, see link below to wiring diagram.


Bob
 

·
Registered
MGTF 135
Joined
·
28 Posts
kpainter65,
Thanks for coming in.
The answer is no. This car remains original.
Nineteen years with me. Head gasket failure many years ago, a few hydragas spheres replaced, and that has been all.
Engine run very well and the car drives fiene. But as from as last week end, every time I close her -with the remote- rear mirror lights remain on, and also the red alarm light in the dash remain solid red, not flashing as it did before.
Mike
Sorry I can't help you any more, all I've ever owned are TF's where everything is controlled by the ECU. I think the simplest experiment would be mgbob's suggestion (trace the wiring), but I've just had a thought, have you tried to change the battery in the fob? I ask this because I had some strange things happened a few years ago with locking, unlocking, and so on, this also seemed to happen suddenly. Changed the fob battery and everything worked a treat. It MIGHT just work for you.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Grateful for your help kpainter65 and mgbob.
I believe that you both may be right. The problems in my F seems to come from multiple causes. The door lock system obviously does not function well. The door closes with the fob -mirror lights keeps on, as said-. But I also found that the boot hinge had some damaged cables. Brake lights still function, except the central boot light, no lights on opening the boot, and -to make things worse: no reverse lights.
So I have interrupted battery connection.
My main trouble is that I live in Mendoza, west of Argentina. I love my F but she is the only one in my Province. And as far as I know only about a dozen of MG F`s in Argentina. No service at all!
Thank you very much
and Merry Christmas for you all.
Mike

JM Vega-P. M.D.
Mendoza - Argentina
 

·
Registered
Joined
·
21 Posts
I just tried shutting my door and locking the car, with the boot open. It did what you say above - mirror lights stay on.

Once I shut the boot the led flashes rapidly, the blinkers flash and the mirror lights go out.

So likely that the boot wiring damage means the bootlock microswitch isn't 'talking to' the Body ECU, and it might just be a matter of fixing that wiring.

David
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Hi David
You may be right, but there are some different failures in my F. No difference with boot open or closed. The doors can be closed or open with te fob. The led remains solid red. As said, found some wires damaged, no third light, no reverse light, and when I press the clutch pedal brake lights come on! . Quite troublesome. However I agree with you about that is very possible that the bootlock microswitch is playing a major role in the failures.
Thank you very much David

Mike
 

·
Registered
Joined
·
21 Posts
If the Body ECU is not getting an input from the boot lock microswitch it'll "think" that the boot is open at all times, even when you've closed the boot. My quick test produced the symptoms you've described - the alarm system locks the doors, but waits till [the microswitch indicates that] the boot has been closed before completely arming itself and turning the interior lights off. If there's no input from the microswitch, ECU waits forever because it "thinks" the boot is open.

The boot light is turned on by the boot lock microswitch. If both the boot light and the eye-level brake light aren't working, then you have open circuit/s in that wiring into the boot lid. Also suggest you check the earth point - all the rear lights earth through a stud behind the carpet, low down on the left side of the boot. If it's high resistance you get blinkers affecting brake lights etc.

Clutch pedal >> brake light is probably unrelated could clutch pedal movement be affecting the brake pedal switch or wiring under the dash?

David
 
1 - 10 of 10 Posts
Top