MG-Rover.org Forums banner

1 - 8 of 8 Posts

·
Registered
mg_zt
Joined
·
90 Posts
Discussion Starter #1 (Edited)
Hi everyone,

I am trying to do a MGF 143VVC MEMS2J -> 160VVC MEMS3 conversion, and make it into a detailed how to.
I will be taking all the pictures as I go, linking in the various pin outs / details etc.

I have spent 2 years restoring MGF Abingdon VVC #3, and this is really going to make the most of a lovely car.


So onto my starting points / questions.

I am starting a conversion from MEMS2J to MEMS3 on my MGF to safe guard its future and get the best out of it with some remapping.
I wish to keep the car running during this as its just finished a 2 year full restoration - guess I should have done this at same time :)


So far I have gathered up:
160 Inlet man with injectors / tmap / iacv sensors
Cam cover / coil packs / ht leads etc.
ZR160 ECU

Now onto what I still need and some questions:

  1. I require an example MEMS1.9 or 2J VVC and a seperate MEMS3 VVC loom. I have part of a 135TF mems3 loom with the ECU bottom plug but missing the MRFU section and as its not VVC I could really with with a real TF or MGF MEMS3 loom.
    • Has anyone out there got either one or both of these engine bay looms please.?
  2. As I have the 160 with no fan driver I heard, is it a simple job to
    • wire in the temp sensor to the ZR ecu, and it works,
      • or do I move to my own engine bay temp setup,
      • or the later TF wire in parallel with front fan setup.
  3. I have remapping software thanks to Andy Reville and ability to recode the ZR160 ECU if need be.
    • Do I need to make any changes to it to move over to 160MGF setup please let me know or are they both the same, maybe the fan is a difference from question2?
Any other advise would be great at this time, before I start cutting things apart...

I am looking in detail at a good guide on the MGF register, but if you are aware of any MEMS2J specific guides please let me know...
Motorbike throttle bodies on a K-series - and run on MEMS3? - Page 13 - The MGF Register Forums
 

Attachments

·
Registered
mg_zt
Joined
·
90 Posts
Discussion Starter #2
All parts have now arrived ( except 160 coils - but buying new. )
I will do a full conversion how - to with pictures if anyone is interested.

Stay safe.
 

·
Registered
mg_zt
Joined
·
90 Posts
Discussion Starter #4 (Edited)
So I have started the loom conversion and I am taking lots of pics for reference, but came across my first of probably many gotchas.... I have a mems3 loom from a 135, and adding VVC to it, as the 160 MEMS3 loom is from a ZR so only taking VVC off it, as its not really close enough to correct MGF loom.
So here is the issue, in early mems1.9 / 2J MGFs the oil filter had 2 sensor, one for gauge in the center console and one for the ECU.. Now at some point looks like all mems3 cars moved over to using a 4 pin sensor.
Were I am confused as that as the oil temp sensor has been replaced on the VVC with a seperate feed beside the VVC unit itself. what sensor should be used on the 160 MEMS3 MGFs / TFs. Is it the 4 pin sensor, but only 2 of them acutally connected, or is it a similar 1/2 pin sensor as used in the early cars.... I can see from the wiring diagram that the oil VVC sensor should be on pin 6 and 32 which is currently where a blue wire from this 4 pin sensor resides....

Here is some pics for reference of the mems3 4 pin type, if anyone could send me a picture of their oil filter area / sensor used for a MEMS3 VVC car I would appreciated it.

I have just uploaded the mems3 circuit diagram which seems to show the oil temp vvc sensor and the oil temp sensor at the filter both being used in parallel... Would love this confirmed by someone... thanks.
 

Attachments

·
Registered
mg_zt
Joined
·
90 Posts
Discussion Starter #5
There are plenty of posts on here about how to remove your engine safely in an MGF, so lets start there, and get to this point...
I followed this article Engine Removal mainly along with an MGF RAVE manual for support, but a key piece that is missing is disconnection of the hydragas feeds, either from under the chassis or at the units themselves ( which is what i did ). Mainly I want to be able to bleed as little air as possible at the end, so I blocked them up again, and will put some pressure into the system and jack the legs up completely till fluid comes out again at reassembly time..
 

Attachments

·
Registered
mg_zt
Joined
·
90 Posts
Discussion Starter #6
Ok I have got a full document written here with all connections where they come from and where they join to.. I am currently updating to use links to point to circuit diagrams and show connector pictures, so I am not breaking any copyright laws... and then add pictures with some How To comments.

For now I only have one question remaining..
If you look at a MGF circuit diagram in either EU2 or EU3 mode with ABS and non ABS. With non ABS its a red wire from the LH rear abs sensor, and with ABS its a slate and black wire coming from it says P23 of the ABS module at the front of the car.
Now I know that the car will run just fine without it, it will just report random misfires on occasions when it shouldn't.

First thing is when I check my MGF its not the same ABS unit - its defo doesn't have the same 3 row connector with 31 pins, its got way more in only a 2 row format... I will upload pictures in a second.
I think it matches this EU2 ABS pin wiring shown here...
http://mgfcar.de/schedules/sb15.jpg

MGF and MGTF have same abs wiring diagram - which can be seen here:
MGF & MG TF Owners Forum - MGF & MG TF Owners Forum

Next the wiring in my EU2 connector doesn't not contain a return wire to the ECU other than the K diagnostics line as far as I can see... Now this agrees with the EU2 vvc diagram which appear to only show this wire linked for automatics - so it looks like MEMS2J didn't expect to receive this signal but I want to double check this.

Maybe there is a pin out on this ABS ecu which allows for this information to be returned, if so which pin on this older ABS unit is it, and which colour - its not there by default it would appear....

On non-abs models it comes from the LH rear abs signal (rough road speed sensor) so is it possible to just splice into this red line and send it instead...
I have read that the number of signal changes / counts are different something like 800 vs 3000 per mile so do i need to update the ecu if I did this modification?

Has anyone completed the MEMS3 upgrade on an ABS vehicle, and then connected this misfire speed signal, to this older type of ABS unit.

Anyone any other ideas on this one.... For now I may leave the wire blocked off but outside the main plug so I can add to it easily in future, but for now it will run just fine without it- I just wanted to finish off the picture...
 

·
Registered
mg_zt
Joined
·
90 Posts
Discussion Starter #7
Here is pic of my abs unit and wiring for reference... as its different from that expected in mgf circuit diagrams.
20200529_013802.jpg 20200529_013806.jpg
 

·
Registered
mg_zt
Joined
·
90 Posts
Discussion Starter #8
Ok, so I have written a full how - to for upgrading the MGF from 143 (EU2) to 160 (EU3) as well as a how to add VVC to a normal 120 / 135 MEMS3 loom.
For now here is the first stage I have made available on onedrive, which is the full pin out / conversion listing - the how to will be added shortly.

 
1 - 8 of 8 Posts
Top