MG-Rover.org Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi all,

Please could somebody help me out??

I love my MG to bits but the last few weeks im a bit fed up with her, she keeps letting me down..

4 weeks ago I had her serviced, got a full major service done. The car is a 2003 "53" and had to have the alternator replaced and 4 new tyres, the brakes need doing in about 4 weeks time.

The door motor on the passenger side went about 6 mths ago, it still locks but each time I open/close the door it makes a horrible screeching sound...

Now the last week, the alarm keeps going off for no reason wot so ever, and yesterday it really came to a head. The alarm went off and the key fob stopped working. The immobiliser was just buzzing inside the car...In the end got the AA out who couldnt fix it, towed me outside and it still didnt work...towed me to where I had it serviced where I was stick for 5hours!!!!! and they couldnt stop it...The 2 emergency access codes given were incorrect and we couldnt over-ride the immobiliser...eventually I got the spare fob brought up and that seemed to do something BUT they said they couldnt understand it cos they has replaced the batt on the fob and it seemed ok but then told me it had gone barmy and the fob was now faulty...

I drove away and now the windscreen wipers wont shut off!!!!

Anyone had this problem with the alarm or any1 know how to fix it????? I leave my car at work for 6-7hrs per day and dont want it to happen when im not there... Could it be linked to the broken door motor??

Will appreciate any advice

Lou
 

·
Registered
Joined
·
17,398 Posts
First check...inside rubber shround near right tailgate hinge for chaffed wiring. Unusual for a young car, but possible if the hatch is used frequently.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Thanks for the tip....

Just had a call from the peeps who serviced it and they said as the key fob was faulty it wouldnt have been arming the alarm correctly which would cause the alarm to go off...Need to get a brand new key fob from MG...Any ideas on how much I should expect to pay?

booked my windscreen wipers in for Tues....
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
Well, called Mg and asked them how much its gonna cost for a new key fob (its the 3 button 1 after all I think, oval and 3 buttons on but only 2 are used)

they said £96.13....does this sound right to any1?? seems a little harsh!!!

also, as posted in another thread, some rotten bugga stole my RH side side skirt/moulded sill finisher and Im glad I have found a few on e-bay cos they were gonna charge me £280 for the part and fitting...when I 1st brought the car, they charged me £191 for both as an added extra!!

so, in the last 4 weeks have spent £1200 on fixing the car, and in the next 4 weeks there will be another £500-600 spent on more repairs and parts (and the only thing that isnt necessary is the side skirt but it dont look right without it on)...thank god for e-bay!!!! just bothers me im spending all this money and its not increasing the value at all and ive already lost 10k on the value in 2 yrs....
 

·
Registered
rover_45
Joined
·
11,619 Posts
Hold on a min. I think this is a case of a faulty BCU or SCU. In the later cars with the oval 2/3 button fob they scrapped the normal MFU that Rover had been using for years in favour of a BCU and SCU to control the stuff. Now I think one of these has broken. I have only ever since this sort of thing once on a 45 with climate and if you disconnect the BCU for about 10 mins or so and plug it back in again all should be well. The only snag is it's in the middle of the dash so disconnect your car batter for at least 30 mins or so and try that.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
Sejin26 said:
Hold on a min. I think this is a case of a faulty BCU or SCU. In the later cars with the oval 2/3 button fob they scrapped the normal MFU that Rover had been using for years in favour of a BCU and SCU to control the stuff. Now I think one of these has broken. I have only ever since this sort of thing once on a 45 with climate and if you disconnect the BCU for about 10 mins or so and plug it back in again all should be well. The only snag is it's in the middle of the dash so disconnect your car batter for at least 30 mins or so and try that.
Cheers for that, sorry to sound thick, I know wot an MFU is buts wots BCU/SCU??

Been using the spare fob since and touchwood ive not had a problem with it, its all been locking fine and had no alarm problems wotsoever...(well I gotta have 1 thing going right on the car) :)
 
1 - 8 of 8 Posts
Top