MG-Rover.org Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
looking for some pointers got the SRS light on the dash.done all the usual checks under seats and the rotary coupler all are sound and working any ideas where to look next before I book it into a garage.just incase it’s a simple fix
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Find someone local that's got a Pscan or buy one, it'll tell you where the problem is
Where can I get it or how much is Pscan do you know please ?
Did you disconnect the seat connectors and give the contacts a good clean?
Yes disconnected then reconnected the connectors with the seats out what did you mean cleaned them ? I checked them and there didn’t seem to have any corrosion on them 🤷🏻‍♂️
 

·
In the Garage
MG TF
Joined
·
33,655 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·

·
Registered
Joined
·
1,350 Posts
SRS ECU? Unlikely based on past posts. My bet is on 1. Seat connectors 2. Connector to the steering wheel airbag.

For those of us who have a passenger airbag, I do not recall any post on this, probably because the connector is rarely 'disturbed'.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
So after chatting to my neighbours in work yesterday I found out he does a bit with land rovers.so borrowed his diagnostics found a few codes so deleted them and this one come up guess its the issue 🤷🏻‍♂️ Rectangle Office equipment Gadget Font Display device
 

·
Registered
Starlight Silver MG TF 135
Joined
·
146 Posts
Based on my bitter experience with similar persistent/intermittent SRS light on a Vauxhall Vivaro van which I converted to a camper van, I suggest you cut-out and replace the standard under-seat connector (on the LH seat, if the message on your neighbour's diagnostic kit can be believed). Disconnect battery and allow 20 minutes first. I was convinced my re-wiring (to substitute Renault Scenic seats for Vivaro seats) was at fault. EVENTUALLY, I realised that the cheap-and-nasty Renault electrical connectors were at fault. I cut all that cr....p out and used toffee-strip to connect raw wires. Never any problem since, with van bounced all round Europe.
 
1 - 12 of 12 Posts
Top