MG-Rover.org Forums banner

1 - 7 of 7 Posts

Registered
Joined
17 Posts
Discussion Starter #1
Hi all again,

So the next issue I am having on my TF is to do with the reversing lights.
Basically they don't work 馃槖
Or they didn't.
So after reading a similar topic on this forum I investigated the reverse light switch located at the gearbox. I disconnected this switch and bridged the wires and "hey presto" the lights came on and the rear parking sensors i had recently installed start beeping at me. Yey!!!!
So this gave me reason to believe it was a faulty switch.
I ordered a new one from RimmerBros for the TF, which took an age to get delivered. And when I finally went to install it I discovered it wasn't the correct size.
So i ordered another one from another place on ebay which stated it was for the TF, and guess what? This was the incorrect size as well.
The one I require has a wider diameter thread than the ones I have purchased.

Does anybody know where I can get the correct part from? Or the item number at least?
I don't really need any more incorrect-sized switches. Although they could make an unusual stocking filler.

Thanks for any help.

By the way, the car is a 2002 (02) plate MGTF 135 if that helps at all?

Thanks again
 

Registered
rover_45
Joined
533 Posts
I would try cross checking the part number with other vehicles that use the same gearbox. Without looking it up I expect the TF uses the PG1 gearbox - if so look at Rover 25/45 (MG ZR/ZS) with engine sizes 1.8 upwards.
 

Registered
mg_tf
Joined
1,554 Posts
Both the MGOC parts CD and Rimmer Bros both list 'CDU51' as the part name for the original part. Rimmers lists an aftermarket part as 'CDU51P'. It's much cheaper than the OEM part. I have changed this switch and I'm pretty sure I ordered the aftermarket part from Rimmers and it fitted - well at least the thread did. It turned out to put the reversing lights on all the time - because although the switch worked, the little linear plunger at the end stuck out a smidge too far. I had to insert an extra washer to get it positioned correctly in depth.
I've had trouble with Rimmers before in terms of being sent the wrong part. I asked for a pair of rear droplinks, left and right. They sent me two left ones. I asked them to send me one right one again and they sent me a left one again! I think they had put parts in the wrong bin in their warehouse and just assumed the binning was correct. Eventually I told them to check the part number on the plastic bag was correct before they tried sending me another droplink...
 

Registered
Joined
1,070 Posts
I have never had a problem with Rimmers and I order all my stuff from them as I cannot buy the parts in Switzerland. Used them for 15 years. Bin mistakes can happen of course........

You can call Rimmers and ask them which will fit your TF, quoting your Vin number. I have an MGF so I cannot help you
 

Registered
rover_45
Joined
533 Posts
CDU51 appears to be the correct part number for all PG1 usages I can find including Freelander 1. . Rimmers have a pattern part and an OEM part in stock. Maybe take your original switch to your nearest Land Rover specialist (or even dealer)?
 

Registered
Joined
17 Posts
Discussion Starter #6
Thanks all for the replies. I have read that it is the PG1 gearbox so surely suppliers know the part that will fit this gearbox, right?
Anyway, I have gone and ordered one from another well known MG parts supplier and after emailing them first before purchasing the item there should be no excuses this time. Think the CDU51 bit sounds familiar.

So far this has proven to be a rather expensive switch

While I am on here, does anybody know which relay I require for the heated rear window?
The car has a hard top and i have discovered that the wiring is in situ for this behind a blank switch.
I have purchased a switch and connected it all up as well as fitting one of the yellow, multi-function relays to the fuse box.
However, nothing seems to happen when i press the switch, either with or without the engine running.
The light on the switch does not light up.

I am thinking it's the relay, but don't want to add a collection of assorted relays to my ever growing collection of reverse light switches.

Any advice is appreciated
 

Registered
'06 MG ZR +120 (HQM) '04 MG ZR 105 (IAB)
Joined
9,302 Posts
I ordered a new one from RimmerBros for the TF, which took an age to get delivered. And when I finally went to install it I discovered it wasn't the correct size.
So i ordered another one from another place on ebay which stated it was for the TF, and guess what? This was the incorrect size as well.
You haven't quoted any part numbers, so it is difficult to know whether you were sent the wrong part or whether the parts now being supplied under the correct part number are in fact not the correct part.

XPart are now supplying all sorts of differently sourced parts as 'Genuine MG Rover' which are not from the same manufacturer/supplier as the MG Rover originals (some parts are in fact the identical part to those available as aftermarket alternatives from most motor factors!), so it would not surprise me if some of them are slightly different.

I've had trouble with Rimmers before in terms of being sent the wrong part....
I have had similar issues a couple of times - on both occasions it turned out that XPart had fixed the wrong part number label to the packaging. It isn't always Rimmers fault ;)

....does anybody know which relay I require for the heated rear window?
If your TF didn't originally have a hard top/heated rear window, I doubt if the relay would be present to start with - I think it is one of the yellow ones (part number YWB10012) - MG Rover stuck to the same relays as much as possible and only used a small number of different ones in any case.
 
1 - 7 of 7 Posts
Top