MG-Rover.org Forums banner
41 - 53 of 53 Posts

Rover Lifestyle
Rover 200 Rover 600
Joined
13,748 Posts
Discussion Starter · #43 ·
NOTE that in some cases in MG F cars, when Heated Rear Window relay (HRW) is not mounted (for example there was no hard top when leaving factory), relay base does not need to be present below two other relays on the right hand side of the fuse box (Window Lift Relay and Engine Bay Fan Relay) as per picture below:

135838

Relay base can be tucked away behind fuse box and need to be searched for (on next picture you can see HRW relay base with yellow HRW relay mounted behind fuse box):

135839
 

Registered
Joined
1 Posts
Thank you Roverlike. My 2003 TF steppy won't start (it's not the battery) and I hope I can find a solution in the wiring. Possibly a wiring problem or maybe the starter relay which I didn't know existed.
 

Registered
mgf vvc, rover 111si
Joined
34 Posts
Dear Roverlike, just to add my thanks to the other comments for brilliant, very helpful information. My MGf has just failed its french MOT on lights; bizarrely i cured a sidelight problem the day before, where fuse kept blowing - by cleaning contacts putting new fuse in. Then, today, it failed on all sidelights, number plate light and fog lights. I will use your information ot track the problem.thanks patrik
 

Registered
Joined
83 Posts
Dear Roverlike, just to add my thanks to the other comments for brilliant, very helpful information. My MGf has just failed its french MOT on lights; bizarrely i cured a sidelight problem the day before, where fuse kept blowing - by cleaning contacts putting new fuse in. Then, today, it failed on all sidelights, number plate light and fog lights. I will use your information ot track the problem.thanks patrik
Im suspecting the starter relay may be the problem I cant get voltage on the spade terminal of the starter solenoid Im also getting confused over where the starter relay is Ive taken to photos one is of a box behind the rear seat the other is behind the main ECU rear of the engine is either one the starter relay A lot of photos Ive looked at show it in different places,but has someone pointed out they may me of the MG TF Mine is the MG F So useful these forums Len
 

Attachments

Rover Lifestyle
Rover 200 Rover 600
Joined
13,748 Posts
Discussion Starter · #49 ·
Im suspecting the starter relay may be the problem I cant get voltage on the spade terminal of the starter solenoid Im also getting confused over where the starter relay is Ive taken to photos one is of a box behind the rear seat the other is behind the main ECU rear of the engine is either one the starter relay A lot of photos Ive looked at show it in different places,but has someone pointed out they may me of the MG TF Mine is the MG F So useful these forums Len
In your picture behined engine ECU you see metal cage. Within that metal cage you will find multirelay black box. Multirelay black box consists of 4 relays from which one is starter relay. You do not have single starter relay, but starter relay is part of mentioned multirelay box. You cannot separate starter relay from this multirelay box. You can exchange only whole multirelay box.
 

Registered
Joined
83 Posts
Now I have a working meter I have started to check various voltages There is no voltage from the ign.
Font Parallel Engineering Pattern Paper
Font Rectangle Material property Parallel Pattern
switch when turned to start ,to the start relay coil There is a fuse as Ive shown in line but where is this fuse The only one Ive found,marked fuse 16 on the interior fuse board,is for brake and reversing lights There are other voltages missing for some reason The voltage to the contacts on the fuel pump relay contacts id missing ,but there on the inertia switch which is closed so the 12v should be on the fuel pump relay I cant understand why so many voltages are missing Len
 

Registered
Joined
83 Posts
Now I have a working meter I have started to check various voltages There is no voltage from the ign. View attachment 139155 View attachment 139156 switch when turned to start ,to the start relay coil There is a fuse as Ive shown in line but where is this fuse The only one Ive found,marked fuse 16 on the interior fuse board,is for brake and reversing lights There are other voltages missing for some reason The voltage to the contacts on the fuel pump relay contacts id missing ,but there on the inertia switch which is closed so the 12v should be on the fuel pump relay I cant understand why so many voltages are missing Len
[/Re the ign fuse,its almost impossible to see the fuse number on my drawing I thought it was fuse 15 but now see its fuse 19 Len
 

Registered
Joined
83 Posts
Further meter checks I have 12volts leaving fuse 19 but its not getting to the starter relay . Is there another connector ,between the fus and the relay If so ,it maybe where Im losing the other power sources Len
 

Rover Lifestyle
Rover 200 Rover 600
Joined
13,748 Posts
Discussion Starter · #53 ·
Yes, there are 2 connectors which should be just beside this multirelay in the car. On the same place where you took out the relay. 1 connector should blie or light blue while other one should be black.
 
41 - 53 of 53 Posts
Top