MG-Rover.org Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi Guys, My Rover 220 turbo coupe, has never had interior lights since I got it. Previous owner had removed bulbs, and when I refitted them, still got no interior lights, but the alarm started going off at random, and would not allways set. test meter on the interior and boot light, showed about 3.5 volts instead of 12 volts. checked courtesy light switches for poor earthing, dirty contacts etc.So I suspect that as there was only 3.5 volts on the light circuit, the alarm circuit was detecting a current drain somewhere(as if a door was open) and so gave an intrusion alarm. I see from my circuit diagram that the interior lights are controlled by the MFU. So aqured a replacement MFU from scrappyard, fitted it , no change. Thought it may have been faulty, so got another one, same symptoms! Since then other functions on the car have gievn up the ghost. Rear wiper, Heated rear window, intermittant front wiper,etc So my questions are? !. Do all MFU's have all the functions in ,ie do the ones fitted to low spec cars, say without rear wiper, have the same MFU as top of the range cars that have all the toys
2. Do MFU's go faulty often,so maybe the ones I got from the scrappers were faulty anyway? I have got them from Rover 214 pre bubble shape cars, Would these use the same MFU as my 94 220 T coupe part numbers look very similar, I have a selection of YWC 10003 and YWC 10004 units, but now unsure as to if they are ok or not. Will buy a new one from dealers if I have to to fix the problems, Tried the test of holding in the Heated rear switch and listening to the beeps, but I get no beeps at all! does it use the same beeper as the lights left on alarm? if so, that has never worked anyway!

Would appreciate it if the Gurus could come up with some tips on this,

Cheers Nightfirer220t
 

·
Registered
Joined
·
176 Posts
Have you checked that the door switches work?

If these are broken then your interior lights will not function and the alarm will not set because it thinks a door is open. I had this problem on my 97 VVC and replacing them cured the interior light and the alarm setting problem.

Edit: Missed the part about the other functions not working, have you checked the connections to the mfu in the fusebox? I would have thought that it would be best to try an source an MFU from 220 coupe/gsi as they have different engine types to the 214's so probably a different wiring loom.
 
1 - 2 of 2 Posts
Top