MG-Rover.org Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hey i drive a 220 sdi i think my turbo isnt kicking in or ive lost back pressure either way when i accelerate i lose pretty much everything past 2 and a half thsousand revs a freind of mine said its porbably an intercooler pipe thats gone but where would the oil come from? i have a bit of black smoke too and sounds almost liek the exahusts blowing but in the front? any help would be appreciated cheers .
 

·
Registered
Joined
·
1,477 Posts
Same problem a few lads on here had includeing me,you can bodge it for now with a short bit of pipe and jubilees but dont go for the original when buying new pipe, get a silicone one made up it wont swell it holds boost better and wont split.
Cheers scott.
 

·
Registered
Joined
·
25,606 Posts
The replacement originals are better than the standard original ones as they seem to have amended the design as it was such a common problem. The originals allowed the oil vapours in the pipe to degrade and soften the rubber leading to the pipe failing. The newer ones have an extra flurosilicone?? liner inside the pipe to prevent the oil attacking the rubber.
 

·
Registered
Joined
·
26 Posts
What hosing/insert size&lengths are you using there?
Where did you get them from?

MY IC hose went last weekend =(

cheers,

Rich
 

·
Registered
Joined
·
1,477 Posts
sorry it took soooooo frickin long to reply had trouble with net.

What hosing/insert size&lengths are you using there?
Where did you get them from?

MY IC hose went last weekend =(

cheers,

Rich
i took my old split hose to midland performance centre in walsall and they made me up this exact copy

Aye Scott, lovely setup, tell us what you've used with it!
do you mean my other mods??
cheers scott
 

·
Registered
Joined
·
3,056 Posts
there you go fob much better looking than the original and cost the same.
cheers scott.


That's nice and I knew that was an option, but, you, I would guess, must have three different pieces there and it must have cost a lot more than £35, or it deffo would've from my nearest rip-off supplier for that stuff. :mad:
 

·
Registered
Joined
·
1,477 Posts
Right got it, alu tube is 56mm in diameter top tube 110mm and bottom tube is 210mm in length. Silicone hose is 57mm in diameter top hose is 190mm, middle 240mm,bottom 190mm in length.
The hose mm is rough cos they bend and damn i need a catch tank anyone know a diy kwik fix?
Cheers scott.
 
1 - 16 of 16 Posts
Top