MG-Rover.org Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
348 Posts
Discussion Starter · #1 ·
This might be nothing, but i was just checking the levels today and saw this in the engine (sorry the Pic is a bit big and pants, off my phone!):




View from other side:





There seems to be a little pipe that has snapped off that comes from what i think is the turbo.
What is it? and is it essential?

Thanks for any advise!

Will
 

·
Registered
Joined
·
3,759 Posts
hello, thats the vacuum line from the egr valve if the engines running ok then its not a problem for the mo but id connect up again.
 

·
Registered
Joined
·
348 Posts
Discussion Starter · #3 ·
Thanks for that, it looks like its snapped off, will it be an expensive job to get a new one of them things?

Thanks

Will
 

·
Registered
Joined
·
3,759 Posts
i wouldnt of thought it would be its only a rubber pipe cant you see the pipe hanging anywhere its quite long? sometimes they come loose and hang somewhere.
 

·
Registered
Joined
·
348 Posts
Discussion Starter · #6 ·
There looks like there is ment to be 2 pipes going into that thing. One of the pipes is still connected, but the other is snapped off, its hanging down (i can see the bit of plastic in the end of the hanging pipe). So i will need a new one of them things that the pipes are connected to. (sorry for my complete lack of technical terms!!)
It looks like its been off a while, i havent realy noticed anything adverse, my abs is playing up but i think thats just the relucter ring.

Thanks
 

·
Registered
Joined
·
3,759 Posts
no probs if you aint got a service manual i suggest going on ebay and get one on disc they are the dogs danglies only a few quid.
 
1 - 8 of 8 Posts
Top