MG-Rover.org Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
456 Posts
Discussion Starter · #1 ·
Well to be honnest i am getting a little downhearted again about this damned car!!

I am seriously thinking about chopping it in and getting a new one, its a 99 reg 216, done 45k

and it has some funny problems, firstly starting is becomming a bit hit or miss, it just keeps chugging over untill it eventually catches, yesterday i had just one spell of complete and utter power loss, its just had a new gearbox and clutch (which took ages to sort out) and i am sure that there are a few other dodgy bits here and there (namly a bit of rust by the boot hinge that will have to be cut out and filled with weld! and a rusty door)

Any ideas on the starting probs and the power loss?? and is it worth keping or selling? It is going into the bodyshop anyway to get some insurance work done, so the minor bodywork stuff will get done

anyone want to make me an offer????
 

·
Registered
Joined
·
25,606 Posts
Have you replaced any of the ignition parts? If not then try a new set of HT leads and distributer cap and rotor arm. If this doesn't help and the car seems to cut out randomly especially once the car gets warm then try replacing the crank position sensor (it may have been disturbed when the new clutch was fitted so check the electrical contacts first)
 

·
Registered
Joined
·
456 Posts
Discussion Starter · #3 ·
well it drove to scotland and back fine then has just seemed to pack up
will take it to rover to get eheir opinions, and get them to read the ecu and find the fault that way

then it is the bodywork to get sorted, a slight insurance job and then its off to market!!

Thinking of getting an IS 200!!
 

·
Registered
Joined
·
1,117 Posts
check battery terminals, earths and the battery itself.

ecu wont be able to pick up on most ignition or starting problems
 
1 - 4 of 4 Posts
Top