MG-Rover.org Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
5,550 Posts
Discussion Starter · #1 ·
Ok, the alarm just went off on the ZTT. When we checked the window wipers front and rear was working and ALL of the elctrical systems were FULLY FUNCTIONALl!! No iginition key or anything? Its raining is this an elctrical fault or an attempted burglary? Need advice fast as the alarm keeps going off ???
WTF?
 

·
Registered
Joined
·
25,606 Posts
Could it be that the ignition relay is stuck in the on position. This would set off the alarm and also allow everything to be operated as normal. The same would apply for a faulty igntion switch too.
 

·
Registered
Joined
·
5,550 Posts
Discussion Starter · #6 ·
The thing is that its been sat there for well over 5 hours and only just started now. Took her for a drive and the wipers went balistic and then stopped. not ideal when its pissing it down....
 

·
Registered
other_manufacturer
Joined
·
2,464 Posts
jonesey2k said:
could it be water getting into the ecu and screwing it up? the engine bay looks dry.
Cleared out the middle drain recently ?

Had about 9 inches of rain water in mine, literally. Took a hard sharp right hand bend one day and water came gushing out the SIDE of my bonnet, confused the **** out of me !

Anyway, there is a "black box" above the drain, if this area fills with water, your box will be soaked.

Why they put it there is beyond me. Seen a few threads in the past about the middle drain becoming blocked and filling up, causing all sorts of ecu probs.
 

·
Registered
Joined
·
5,550 Posts
Discussion Starter · #9 ·
Yes it is raining. My dads going to take it into the dealers tomorrow when we pick up my mums new zr to see whats going on. Its a bit dubious tbh.
 

·
Registered
Joined
·
5,550 Posts
Discussion Starter · #10 ·
Ill have a look at this drain in the morning. Where about under the bonnet is it?
cheers for all the replys.
 

·
Registered
other_manufacturer
Joined
·
2,464 Posts
It's a bugger to get to, which is why no one clears it out, which is why it always blocks up !

Done mine so often now I have it down to a 15mins job :)

Remove both window wipers, tipex across the bolts/wiper arms so you can put them back on in the same place. Remove both plastic covers from the scuttle panel (where you'd check brake fluid)

Once off, pull off the rubber trim that runs the width of the bonnet, remove the plastic screws on each side too. Then pop up the 8 or so plastic plugs that hold the top panel to the windscreen, small screwdriver works fine.

Remove the entire scuttle cover, grab a wire coat hanger and a torch, peer down inside, about 20" down, you'll see more water than you can shake a dowsing stick at :)

Shove the coat hanger through the rubber gromet where all the leaves/debris/crap have blocked it up.

Sounds complex, but its not that hard once you've done it a few times.

I hope this is all it is !
 
1 - 12 of 12 Posts
Top