MG-Rover.org Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi folks..

Hoping someone out there is able to help, or at least know the situation i'm in.

I have a 2002 ZS. A few months back I noticed it started loosing water. Each week it needed filling up, to the point where the resevoir was empty and has a dirty residue on the bottom, i suppose this could just be general dirt.

With this the car heater goes stone cold and the temperature gauge rises up to the 3 quarter stage sometimes when the fan eventually cools the engine enough for the gauge to drop.

I took it to the AA service centre, whatever their called now, and they said instantly the head gaskets gone. £500 + to repair. I wanted a second opinion, so took the car to a 2nd garage where they said head gasket was fine but i needed a new water pump and manifold and numerous other conected bits £480. The 3rd opinion was the above aswell so i paid it.

The problem has now re-occoured and the car has been back 3 times, for them to say there is no problem, no leaks... My argument is, where the hell is the water going then, because i'm back to filling it up weekly.

Anyone got any ideas what I should look at? or what to do? The garage are obviously not gonna do anything now...

Regards

Duncan
 

·
Registered
other_manufacturer
Joined
·
34,938 Posts
welcome to the forum.

check the coolant tank cap and inlet manifold gasket. check the radiator.

you are running the risk of the head gasket going.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
thanks for the quick reply!!! and the welcome!

Hate to sound stupid, what am I lookin for on the cap? residue or that it is sealing?

I think I have had a new inlet manifold and gasket, is this something i can look at myself.

The radiator does have a patch of corrosion on it apparently but nothing bad enough to leak, so I've been told, and i'm sure that if they wanted to stiff me gettin a new one they would have done.. i think..lol..

Maybe I should just get a 2.5 V6..lol..

Cheers

Duncan
 

·
Registered
other_manufacturer
Joined
·
34,938 Posts
check to see if it leaks under pressure. best thing to do is replace it, they are only a couple of quid.

can you see any visible leaks? its got to be going somewhere. (unless its burning it....)
 

·
Registered
other_manufacturer
Joined
·
34,938 Posts
looking at it again though, sound slike you have a duff thermostat or an air lock too. something isn't right. you need to get it looked at, there shouldnt be any residue in coolant. get it flushed, the thermostat replaced and refilled. do all the hoses top and bottom get hot and hard?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
I'll check the pipes in a bit..

I'm only in Cannock and notice your not too far away, are there any garages you recommend taking it to?
 

·
Registered
other_manufacturer
Joined
·
34,938 Posts
the only garage I trust with my car are the Sun Garage (0121 553 0296) in West Brom. Little family run affair, know the K series back to front, inside out etc.
 

·
Registered
Joined
·
5,840 Posts
thanks for the quick reply!!! and the welcome!

Hate to sound stupid, what am I lookin for on the cap? residue or that it is sealing?

I think I have had a new inlet manifold and gasket, is this something i can look at myself.

The radiator does have a patch of corrosion on it apparently but nothing bad enough to leak, so I've been told, and i'm sure that if they wanted to stiff me gettin a new one they would have done.. i think..lol..

Maybe I should just get a 2.5 V6..lol..

Cheers

Duncan
Hi, hope you get your problems sorted.
And sorry to burst your bubble, but the 2.5 V6 can also have HGF issues - just not as common as the 4 cylinder models can be.
 
1 - 8 of 8 Posts
Top