MG-Rover.org Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
3,699 Posts
Discussion Starter · #1 · (Edited)
help me :( eratic acceleration/boosting!!!!

hi guys, got a 220sdi, its been remapped, runs 23 psi.

for the last 2 years ive run the car no problems, but all of a sudden ive got a strange one,

the car appears to not be boosting properly.... its not hitting anywhere near a bar. creeps over 0.5 bar. heres the good bit, when its all nice and hot in the engine im getting very eratic boosting, when on throttle the car literally goes on and off boost. very very jumpy!!!

ive tried a different actuator, with no joy
ive turned the boost riht down (still jumps about)
ive tried ive tried a stanrdard ECU, no joy still does it.

what else is there?

the boost hoses etc are fine as i have had them all off recently to flush the intercooler out as thought it might help the issue!!

im thinking:-
MAP sensor?
poss crank sensor?!
Turbo?
Fuel pump......

:(

any input or tests would be greatly appreciated.
 

·
Registered
Joined
·
25,606 Posts
hi guys, got a 220sdi, its been remapped, runs 23 psi.

for the last 2 years ive run the car no problems, but all of a sudden ive got a strange one,

the car appears to not be boosting properly.... its not hitting anywhere near a bar. creeps over 0.5 bar. heres the good bit, when its all nice and hot in the engine im getting very eratic boosting, when on throttle the car literally goes on and off boost. very very jumpy!!!

ive tried a different actuator, with no joy
ive turned the boost riht down (still jumps about)
ive tried ive tried a stanrdard ECU, no joy still does it.
Sounds like an EGR problem to me. Disconnect and plug the small vacuum pipe to the EGR valve and see if that helps. If it cures the jumpiness but not the boost then it may be that the vavle is stuck open, and you'll have to remove it to close/blank it off.

BTW a 200 ECU can't be remapped unfortuantly. Do you mean it has been chipped?
 

·
Registered
Joined
·
3,699 Posts
Discussion Starter · #3 ·
yes its been chipped.

the EGR is already blanked off, sorry i forgot to mention that.
 

·
Registered
Joined
·
25,606 Posts
Look for frayed wires on number 1 injector then. Also if the problem only occurs when hot it could be the crank sensor as they tend to fail when the engine gets hot. Its not a common fault like the wire chafing on the injectors though.
 

·
Registered
Joined
·
15,938 Posts
back on the block to the riht hand side, its got a black connector on a 1ft flylead, then plugs into plate that mates with the bellhousing aiming towards the gearbox
 

·
Registered
Joined
·
25,606 Posts
If you look down the back of the engine where the engine joins the gearbox the crank sensor is infront and near the driverside driveshaft where it enters the gearbox. You'll probably find a blue electrical plug on the top of the gearbox in this area. Follow the wires down the back of the engine and you should find it. I think it is held in with 1 or 2 small (8mm?) bolts.
 

·
Registered
Joined
·
3,699 Posts
Discussion Starter · #12 ·
cool. cheers giuys, hmmm just been quoted near on 70 quid for a crank sensor?!!? YIKES!

checked pin injector 1 and seems ok.....i take it im looking at hte thin black wire coming off it?
 

·
Registered
Joined
·
25,606 Posts
Yes, check carefully for any splits or chafing of the wire. It quite often rubs on the engine and when this happens the engine gets quite upset.
 

·
Registered
Joined
·
3,699 Posts
Discussion Starter · #14 ·
yeah that wire looks ok but i will get a good look later. :)

ill also check the wires on the pontentiometer. just in case.
 

·
Registered
Joined
·
259 Posts
Sounds like an EGR problem to me. Disconnect and plug the small vacuum pipe to the EGR valve and see if that helps. If it cures the jumpiness but not the boost then it may be that the vavle is stuck open, and you'll have to remove it to close/blank it off.

BTW a 200 ECU can't be remapped unfortuantly. Do you mean it has been chipped?
A 200 can't be remapped???

Why???
 

·
Registered
Joined
·
25,606 Posts
It just can't. Most rover ECU's can't be remapped, they just don't have the facility to have their settigns altered.
 
1 - 18 of 18 Posts
Top