MG-Rover.org Forums banner
1 - 20 of 31 Posts

·
Registered
Joined
·
785 Posts
Discussion Starter · #1 · (Edited)
I must have spend about £1500 have my whole engine rebuilt and put back together. It was the moment of truth yesterday when the mechanic fired it up for the first time. I’ve done 50 miles on the engine so far and it sounds like a piece of ****** and i’m embarrassed to drive it.

Here is a video of the noise http://www.youtube.com/watch?v=tpvwscwW9E0&feature=channel_video_title


Has this happened to anyone else before and does it take time for the engine to settle down?


Kind regards
Jason
 

·
Registered
Joined
·
1,898 Posts
I must have spend about £1500 have my whole engine rebuilt and put back together. It was the moment of truth yesterday when the mechanic fired it up for the first time. I’ve done 50 miles on the engine so far and it sounds like a piece of ****** and i’m embarrassed to drive it.


Has this happened to anyone else before and does it take time for the engine to settle down?


Kind regards
Jason
have you not told the mechanic? :O
 

·
Registered
Joined
·
970 Posts
Shouldn't really sound any different from normal other than maybe a few minutes while the oil circulates round after the rebuild.

What exactly have you had done and by whom because £1500 is a lot of money
 

·
Registered
Joined
·
785 Posts
Discussion Starter · #5 ·
I bought a short motor of a 33k mile mgf £400
I bought a new starter motor £110
New clutch £180
New clutch release arm £20
Head was skimmed (included in mechanic fee)
Russell has been my mechanic and charged me a total of £810 to do all the work (labour)

Plus there have been other parts i've bought for the car.

I've got my MOT in 2hrs time!
 

·
Registered
Joined
·
6,314 Posts
I bought a short motor of a 33k mile mgf £400
Was it tested/stripped also?

Did it come with any kind of guarantee or warranty?

Why was that engine split at 33K?

Sorryt to hear of your problems, and best of luck with the MOT matey.
 

·
Registered
Joined
·
785 Posts
Discussion Starter · #10 ·
Yeah the Head was all done by Russell and the Block (short motor) was from one of the advertisers on this forum.

I'll try and upload a video for you guys to hear
 

·
Registered
Joined
·
785 Posts
Discussion Starter · #11 ·
Yeah your right it should be running sweet. Im so annoyed right now and I have to be in Monaco in a few days time with the car!

It should really run spot on straight away. Russell knows his stuff so ask him what he says!
 

·
Registered
mg_tf
Joined
·
1,996 Posts
My 160 VVC sounds like an Albanian Tractor when I first fire her up. I'll have a special listen later to compare to your video clip.

cheers
 

·
Registered
mgf
Joined
·
237 Posts
Before you fear the worst, double check your spark plugs are all tightened up. You can get a similar sound if one or more of the plugs are not tightened up fully.
 

·
Registered
Joined
·
1,625 Posts
cam bearing is another option it could of failed allowing lateral movement, defo top end, i fixed a guys freelander that made a similar noise it was the choke unit in the intake manifold making the noise
 

·
Registered
Joined
·
670 Posts
If it, as it sounds is the top end, and Russell supplied and fitted it, then he is your first port of call. Did it sound like that when he started it up, as if it did I'm suprised he didn't say something.

He does guarantee his work for 12 months.
 
1 - 20 of 31 Posts
Top