MG-Rover.org Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi Guys, here's hoping you can help me....

I've got an N Reg Rover 214i (the 8v one) that i am experiencing some intermittent problems with.

The car has done 36,000 miles, so i wouldn't expect any engines problems to have cropped up yet, but however they have. the problem is kind of difficult to explain, but i'll do my best....

every now and again, as im driving along, the engine sort of shudders. its kind of like taking your foot off the accelerator and putting it back on again rearrly quickly. it'll do this a couple of times, really rapidly, lasting no more than a second or two, then be fine again for ages.

i commute about 70 miles a day in this car, and every time its done it ive been doing about 70/80 mph in fifth, although it might happen in other gears, i just spend 90% of my time doing that sort of speed.

i must admit, im at abit of a loss. im an able mechanic, ut i can't think of what it might be. i reckon its either the injectors, or the throttle playing up. i know the plastic throttle bodies on 214's can be a bit dodgy, from reading this site, but generally a sticking throttle doesn't cause the engine to judder - which leads me to believe that its most likely the injectors.

if anyone has any alternative suggestions/fixes, id be really happy to hear them!!! or has anyone else had this problem with their car?

any help would be very much appreciated!

Cheers,

adam.
 

·
Registered
Joined
·
2,192 Posts
I would consider checking, or changing some of these items first, if not already done..sparkplugs, rotor arm, distributor cap, ht leads, and fuel filter. then see how it goes?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
cheers, will do. im kinda new to this engine buisness, that looks like a fair old list to be getting on with...
 

·
Registered
Joined
·
2,192 Posts
shalmaneser said:
cheers, will do. im kinda new to this engine buisness, that looks like a fair old list to be getting on with...
Well just do one at a time, then test, you may not have to replace all of them..anyone from the list could sort your problem..but which one?
 
1 - 4 of 4 Posts
Top